Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006831 [Squeak] Compiler minor always 12-30-07 02:07 02-06-11 23:48
Reporter mikevdg View Status public  
Assigned To nicolas cellier
Priority low Resolution fixed  
Status closed   Product Version
Summary 0006831: | | [ | unusedVar | ]. Doesn't compile because of "out of scope ->"
Description I'm not sure what the error message means, but I'd expect something like "unusedVar is not used; do you want to remove it?" or at least just accept the method.

The test method that doesn't work is as follows:

test
    | |
    [ | hello | ].

The test method that does work is as follows:

test
    [ | hello | ].
Additional Information
Attached Files

- Relationships
has duplicate 0007232closed nicolas cellier Out of Scope error always displayed when I have a block where a local variable is declared and assigned to but not used. 

- Notes
(0011621 - 337 - 385 - 385 - 750 - 750 - 750)
nicolas cellier
01-03-08 21:49

Yes, it used to propose to remove the variable in 3.9.
But then failed if you select yes...

Since 7155 and inclusion of 0006704 it does fail before asking.
Seems that the patch is at least incomplete...

Anyway, OutOfScope is broken in old Compiler as you can see in 0003448 and 0006720

Yet another raison d'Ítre for the NewCompiler.
 
(0013862 - 75 - 81 - 81 - 81 - 81 - 81)
nicolas cellier
09-07-10 19:15

Could not reproduce any error in 4.2 trunk.
Probably already solved in 4.1
 

- Issue History
Date Modified Username Field Change
12-30-07 02:07 mikevdg New Issue
01-03-08 21:49 nicolas cellier Note Added: 0011621
11-26-08 00:04 KenCausey Relationship added has duplicate 0007232
09-07-10 19:15 nicolas cellier Status new => resolved
09-07-10 19:15 nicolas cellier Fixed in Version  => trunk
09-07-10 19:15 nicolas cellier Resolution open => fixed
09-07-10 19:15 nicolas cellier Assigned To  => nicolas cellier
09-07-10 19:15 nicolas cellier Note Added: 0013862
02-06-11 23:48 leves Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
51 total queries executed.
40 unique queries executed.
Powered by Mantis Bugtracker