Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006846 [Squeak] Morphic minor always 01-10-08 04:20 01-10-09 02:00
Reporter rootbeer View Status public  
Assigned To Damien Cassou
Priority normal Resolution fixed  
Status pending   Product Version
Summary 0006846: MenuMorphs can drop mouse focus
Description Control-click on the Squeak desktop to bring up a menu, then move the mouse off of the menu across the menu's lower edge; the menu loses mouse focus.

Mouse focus is lost whenever the mouse leaves a menu item with a sub-menu, but doesn't arrive at a sub-menu or another menu item within 500 milliseconds (see MenuItemMorph>>mouseLeaveDragging:). This is easiest to do when the sub-menu item is at the top or bottom of the menu, or next to a divider line.
Additional Information The bug seems to be in MenuItemMorph>>deselectTimeOut:, which sets the mouse focus to nil instead of owner. Here's the fixed method:

deselectTimeOut: evt
    "Deselect timout. Now really deselect"
    owner selectedItem == self
        ifTrue:[
            evt hand newMouseFocus: owner.
            owner selectItem: nil event: evt].
Attached Files  MenuItemMorph-deselectTimeOut.st [^] (335 bytes) 01-11-08 07:29

- Relationships

- Notes
(0011676 - 83 - 83 - 83 - 83 - 83 - 83)
Damien Cassou
01-11-08 07:13

I confirm the bug and the solution. Please include that fix in new Squeak versions.
 
(0011677 - 89 - 121 - 121 - 121 - 121 - 121)
Keith_Hodges
01-11-08 07:30

"fix begin"
Installer mantis bug:6846 fix:'MenuItemMorph-deselectTimeOut.st'.
"fix end"
 

- Issue History
Date Modified Username Field Change
01-10-08 04:20 rootbeer New Issue
01-10-08 04:25 rootbeer Issue Monitored: rootbeer
01-11-08 07:13 Damien Cassou Status new => resolved
01-11-08 07:13 Damien Cassou Resolution open => fixed
01-11-08 07:13 Damien Cassou Assigned To  => Damien Cassou
01-11-08 07:13 Damien Cassou Note Added: 0011676
01-11-08 07:13 Damien Cassou Issue Monitored: Damien Cassou
01-11-08 07:29 Keith_Hodges File Added: MenuItemMorph-deselectTimeOut.st
01-11-08 07:30 Keith_Hodges Note Added: 0011677
01-10-09 02:00 Keith_Hodges Status resolved => pending


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
47 total queries executed.
33 unique queries executed.
Powered by Mantis Bugtracker