Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006880 [Squeak Packages] Polymorph feature always 02-01-08 16:43 03-04-08 21:10
Reporter Damien Cassou View Status public  
Assigned To GazzaGuru
Priority normal Resolution fixed  
Status resolved  
Summary 0006880: Using keyboard on lists
Description without UIEnhancements loaded, I can easily select an item on any list
if I type part of its label (open the world menu and type 'save').
With UIEnhancements, it does not work anymore if I use the
#chooseFrom:* methods from UIManager. Can this be readded please?
Additional Information
Attached Files

- Relationships

- Notes
(0011737 - 86 - 86 - 86 - 86 - 86 - 86)
GazzaGuru
02-04-08 17:48

Latest Pinesoft-Widgets-gvc.286 has an attempt at this. Not pretty but may do the job!
 
(0011738 - 129 - 129 - 129 - 129 - 129 - 129)
GazzaGuru
02-04-08 17:50

Should preselect the first matching prefix within each menu column, spacebar to activate, or use arrow keys to navigate as usual.
 
(0011747 - 291 - 315 - 315 - 315 - 315 - 315)
Damien Cassou
02-06-08 07:05

There is some problems:

- if I print (UIManager default chooseFrom: Object selectors asArray) and type 'cop' then Space, it prints 0. (sq3.10-7159dev08.02.1 + Pinesoft-Widgets-gvc.286)

- there is no way of stepping through all the methods which contain 'cop' as it was the case before.
 
(0011748 - 240 - 240 - 240 - 240 - 240 - 240)
GazzaGuru
02-06-08 10:01

I get 5 for that... I guess it works best with sorted choices, can then use arrow keys to move selection up/down. I may have a go at disabling non-matching items though the filter would need to hang around, rather than resetting like lists.
 
(0011862 - 453 - 463 - 463 - 463 - 463 - 463)
GazzaGuru
02-23-08 17:09

For the moment, Pinesoft-Widgets-gvc.287 and onwards will track the selection across multiple columns (bringing the column into view), if the list is sorted then using the up/down arrow keys can select within a column before pressing space. Will work on arrowing of the top/bottom of the column to switch to the previous/next column. Maybe that (when done) will be sufficient... aside from the "current" selector being present at the top of the choices.
 
(0011880 - 80 - 80 - 80 - 80 - 80 - 80)
GazzaGuru
02-27-08 15:48

Have changed things a bit. Try Pinesoft-Widgets-gvc.293 to see if acceptable :-)
 
(0011881 - 215 - 227 - 227 - 227 - 227 - 227)
GazzaGuru
02-27-08 16:09

Best use version 294. Looks like seaside overrides String>>startsWith: to delegate to String>>beginsWith: that answers false if the the parameter is an empty string (wtf), leading to no re-enablement of the choices.
 
(0011901 - 224 - 224 - 224 - 224 - 224 - 224)
Damien Cassou
03-04-08 07:19

It is a bit less simple than what it was before (the user has to use TAB in order to change the column) but it works. It may be better to allow the simple use of UP/DOWN arrow keys to switch over the different possibilities.
 
(0011904 - 163 - 163 - 163 - 163 - 163 - 163)
GazzaGuru
03-04-08 21:10

When I get some time (not having to work Sundays!) I'll have a go at arrowing off the top/bottom of the columns. Will let you know when the future release happens.
 

- Issue History
Date Modified Username Field Change
02-01-08 16:43 Damien Cassou New Issue
02-01-08 16:43 Damien Cassou Status new => assigned
02-01-08 16:43 Damien Cassou Assigned To  => GazzaGuru
02-04-08 17:48 GazzaGuru Note Added: 0011737
02-04-08 17:50 GazzaGuru Note Added: 0011738
02-04-08 17:50 GazzaGuru Status assigned => feedback
02-06-08 07:05 Damien Cassou Note Added: 0011747
02-06-08 10:01 GazzaGuru Note Added: 0011748
02-23-08 17:09 GazzaGuru Note Added: 0011862
02-27-08 15:48 GazzaGuru Note Added: 0011880
02-27-08 16:09 GazzaGuru Note Added: 0011881
03-04-08 07:19 Damien Cassou Note Added: 0011901
03-04-08 21:10 GazzaGuru Status feedback => resolved
03-04-08 21:10 GazzaGuru Resolution open => fixed
03-04-08 21:10 GazzaGuru Note Added: 0011904


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
69 total queries executed.
46 unique queries executed.
Powered by Mantis Bugtracker