Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006893 [Squeak] System minor always 02-09-08 07:35 10-03-09 19:33
Reporter umejava View Status public  
Assigned To andreas
Priority normal Resolution fixed  
Status assigned   Product Version 3.9
Summary 0006893: "Do it" log cannot be parsed if it includes leading spaces and multybyte string
Description If you "do it" in Workspace, the log will be attached to .changes. And we can see the log from "recently logged changes...". But if the expression includes leading whitespaces & multibyte string, reading log fails. This is because we always skip leading whitespaces in parsing "do it" log and do not consider "]lang[" tag.
This patch changes "do it" log not to include unnecessary leading whitespaces, so that parsing succeeds.
Additional Information
Attached Files  DoItLogBlanksTrimmedFix-mu.1.cs [^] (2,128 bytes) 02-09-08 07:35

- Relationships

- Notes
(0011758 - 89 - 121 - 121 - 121 - 121 - 121)
Keith_Hodges
02-11-08 03:41

"fix begin"
Installer mantis bug:6893 fix: 'DoItLogBlanksTrimmedFix-mu.1.cs'.
"fix end"
 

- Issue History
Date Modified Username Field Change
02-09-08 07:35 umejava New Issue
02-09-08 07:35 umejava File Added: DoItLogBlanksTrimmedFix-mu.1.cs
02-11-08 03:41 Keith_Hodges Note Added: 0011758
01-10-09 02:00 Keith_Hodges Status new => pending
01-10-09 02:40 Keith_Hodges Status pending => testing
01-10-09 03:39 Keith_Hodges Status testing => resolved
01-10-09 03:39 Keith_Hodges Fixed in Version  => 3.11
01-10-09 03:39 Keith_Hodges Resolution open => fixed
01-10-09 03:39 Keith_Hodges Assigned To  => Keith_Hodges
01-10-09 03:41 Keith_Hodges Status resolved => testing
10-03-09 19:33 Keith_Hodges Status testing => assigned
10-03-09 19:33 Keith_Hodges Assigned To Keith_Hodges => andreas


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
44 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker