Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006894 [Squeak] Kernel major always 02-11-08 02:26 07-23-13 11:20
Reporter umejava View Status public  
Assigned To
Priority normal Resolution fixed  
Status feedback   Product Version 3.10
Summary 0006894: StartUpList order is broken after the Delay patch installation
Description If you install DelayStartup changeSet in Squeak, LanguageEnvironment is placed after FileDirectory in StartUpList.
However, LanguageEnvironment should precede FileDirectory in start up process, because FileDirectory class >>startUp relies on encoded pathname which must be configured by LanguageEnvironment.
This order is dangerous because Squeak fails to start if you move the image to other encoded path platforms (eg. from Mac to Windows).

I submit a patch for fix this order.
Additional Information 3.8.2 & 3.10 has bad ordered list, because of the DelayStartup patch.
Attached Files  FixOrderOfRegisteringStartUpList-mu.1.cs [^] (1,869 bytes) 02-11-08 02:26

- Relationships

- Notes
(0011757 - 98 - 130 - 130 - 130 - 130 - 130)
Keith_Hodges
02-11-08 03:23

"fix begin"
Installer mantis bug:6894 fix: 'FixOrderOfRegisteringStartUpList-mu.1.cs'.
"fix end"
 
(0014414 - 107 - 107 - 107 - 107 - 107 - 107)
tim
07-22-13 02:56

FileDirectory still precedes LanguageEnvironment in a 4.5 image, so if this is important, it's still broken
 
(0014419 - 420 - 454 - 454 - 454 - 454 - 454)
umejava
07-23-13 01:45

It became less important because recent Win32 VM uses UTF8 path encoding and LanguageEnvironment class>>defaultFileNameConverter was fixed for that (ar 6/3/2007).

But Latin2Environment class>>fileNameConverterClass still returns legacy path converter class, so it could still be a problem. (I think it is minor one, because Latin2Environment user is very rare. Class comment says "so far nobody seriously needed it").
 

- Issue History
Date Modified Username Field Change
02-11-08 02:26 umejava New Issue
02-11-08 02:26 umejava File Added: FixOrderOfRegisteringStartUpList-mu.1.cs
02-11-08 03:23 Keith_Hodges Note Added: 0011757
01-10-09 02:00 Keith_Hodges Status new => pending
01-10-09 02:39 Keith_Hodges Status pending => testing
01-10-09 03:39 Keith_Hodges Status testing => resolved
01-10-09 03:39 Keith_Hodges Fixed in Version  => 3.11
01-10-09 03:39 Keith_Hodges Resolution open => fixed
01-10-09 03:39 Keith_Hodges Assigned To  => Keith_Hodges
01-10-09 03:41 Keith_Hodges Status resolved => testing
10-03-09 19:33 Keith_Hodges Status testing => assigned
10-03-09 19:33 Keith_Hodges Assigned To Keith_Hodges => andreas
07-22-13 02:56 tim Note Added: 0014414
07-23-13 01:45 umejava Note Added: 0014419
07-23-13 11:20 KenCausey Assigned To andreas =>
07-23-13 11:20 KenCausey Status assigned => feedback


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
56 total queries executed.
38 unique queries executed.
Powered by Mantis Bugtracker