Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006924 [Squeak Packages] Seaside minor always 02-14-08 05:51 02-14-08 07:17
Reporter pmm View Status public  
Assigned To renggli
Priority normal Resolution fixed  
Status resolved  
Summary 0006924: WALocale class >> parseCountryString portability issues
Description in WALocale class >> parseCountryString, rewrite it like this:

    | string lines |
    iso2Countries := Dictionary new.
    string := self countryList.
    lines := string findTokens: Character cr.
        lines allButFirst collect:
                [:each |
                | parts |
                parts := each findTokens: $;.
                parts size >= 2 ifTrue: [iso2Countries at: parts second
put: parts first]]
    ]

with two changes: a) Using #findTokens: instead of #subStrings: since
that's what is already in SeasidePlatformSupport; b) Testing that the
result has two items because in my source the second line of the
#countryList is blank.

reported by Paolo
Additional Information
Attached Files

- Relationships

- Notes
(0011779 - 28 - 28 - 28 - 28 - 28 - 28)
pmm
02-14-08 05:52

fixed in Seaside-Core-pmm.53
 
(0011786 - 19 - 19 - 19 - 19 - 19 - 19)
renggli
02-14-08 07:17

Seaside-Core-pmm.53
 

- Issue History
Date Modified Username Field Change
02-14-08 05:51 pmm New Issue
02-14-08 05:51 pmm Status new => assigned
02-14-08 05:51 pmm Assigned To  => renggli
02-14-08 05:52 pmm Note Added: 0011779
02-14-08 07:17 renggli Status assigned => resolved
02-14-08 07:17 renggli Resolution open => fixed
02-14-08 07:17 renggli Note Added: 0011786


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
40 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker