Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006932 [Squeak Packages] Polymorph minor always 02-17-08 11:47 02-19-08 10:17
Reporter Nicolai Hess View Status public  
Assigned To GazzaGuru
Priority normal Resolution fixed  
Status resolved  
Summary 0006932: SystemWindow bypasses Thememanager on makeClosable.
Description When selectiong makeUncloseable and makeCloseable from
a SystemWindow Windowmenu.
The closebutton will be added "unthemed".
Additional Information
Attached Files

- Relationships

- Notes
(0011824 - 16 - 16 - 16 - 16 - 16 - 16)
GazzaGuru
02-18-08 10:45

Investigating...
 
(0011825 - 169 - 179 - 179 - 179 - 179 - 179)
GazzaGuru
02-18-08 11:04

Pinesoft-Widgets-gvc.288 on SqueakSource should clear this up if you'd like to test. The control "boxes" stuff could really do with a through refactoring though! Thanks.
 
(0011833 - 346 - 382 - 382 - 382 - 382 - 382)
Nicolai Hess
02-19-08 08:34

Yes, now it works.
But does it work only for themes provided
by the UIEnhancements-package or for all themes (are there any other?).
After a quick look at the theme integration in SystemWindow
I think there is no separation between controlbox creation
and placement. Or in other words on re-adding one box all other
boxes must be recreated?
 
(0011834 - 235 - 235 - 235 - 235 - 235 - 235)
GazzaGuru
02-19-08 10:17

Just for the UI Enhancement themes. Until I get around to refactoring, #replaceBoxes should be called after using the existing methods on SystemWindow to reinstate boxes after deletion since the box order/layout is now theme-dependent.
 
(0011835 - 20 - 20 - 20 - 20 - 20 - 20)
GazzaGuru
02-19-08 10:17

Closing since fixed.
 

- Issue History
Date Modified Username Field Change
02-17-08 11:47 Nicolai Hess New Issue
02-17-08 11:47 Nicolai Hess Status new => assigned
02-17-08 11:47 Nicolai Hess Assigned To  => GazzaGuru
02-18-08 10:45 GazzaGuru Note Added: 0011824
02-18-08 11:04 GazzaGuru Note Added: 0011825
02-18-08 11:04 GazzaGuru Status assigned => feedback
02-19-08 08:34 Nicolai Hess Note Added: 0011833
02-19-08 10:17 GazzaGuru Note Added: 0011834
02-19-08 10:17 GazzaGuru Status feedback => resolved
02-19-08 10:17 GazzaGuru Resolution open => fixed
02-19-08 10:17 GazzaGuru Note Added: 0011835


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
53 total queries executed.
38 unique queries executed.
Powered by Mantis Bugtracker