Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006989 [Squeak] Any block N/A 03-22-08 15:47 04-08-10 17:21
Reporter matthewf View Status public  
Assigned To matthewf
Priority immediate Resolution no change required  
Status closed   Product Version
Summary 0006989: Squeak still has code under SqueakL
Description Many methods in 3.10.2 have contributions made under the Squeak License. They must all be relicensed before 4.0.

The detailed status of the relicense is at
http://wiki.squeak.org/squeak/3680 [^]

Get the latest version of the relicensing tools here. This image includes tools for examining every method version known to exist:
http://ftp.squeak.org/4.0alpha/ [^]

Outdated instructions on participating in the relicense are here. Updated ones are pending a meeting with the SFC -- Matthew Fulmer, 20 June 2009 http://lists.squeakfoundation.org/pipermail/squeak-dev/2009-February/133862.html [^]
Additional Information Attached is a complete audit of all code that has ever been included in an official squeak release or touched the squeak update stream, from 1.1 to 3.10.2.

However, this does not constitute a full audit of all code in squeak 3.10.2; the following four packages are packaged with squeak but have a significant history outside of the update stream, and no clear licensing statement:
- Monticello
- SUnit, SUnitImproved, TestRunner
- Universes
- Traits

This issue is for tracking the kernel relicense; for the relicensing of these four packages, see my child issues below
Attached Files  fixedin-kenel.txt [^] (60,720 bytes) 02-07-09 04:47
 stillmissing-kernel.txt [^] (17,065 bytes) 02-07-09 04:47
 KernelNumber-PharoLicenseCleanEffort-GabrielCotelli.st [^] (98 bytes) 09-15-09 20:22

- Relationships

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

parent of 0006988closed matthewf Squeak Etoys 4.0 relicense 
parent of 0007277closed Keith_Hodges Squeak Monticello is not license clean 
parent of 0007278closed laza Squeak SUnit, SUnitImproved, and TestRunner are not license clean 
parent of 0007279closed dvf Squeak Traits may not be license clean 
parent of 0007280new  Squeak Packages Universes may not be license clean 
related to 0007281assigned andreas Squeak Packages FFI is not license clean 
Not all the children of this issue are yet resolved or closed.

- Notes
(0012945 - 375 - 399 - 399 - 469 - 469 - 469)
matthewf
02-07-09 04:49
edited on: 02-07-09 05:47

The license audit comes in two forms. fixedin shows all the problematic methods 3.10.2 had, but makes a note of which have already been fixed. stillmissing shows only the methods that have not yet been resolved

The first step toward resolving this issue was to apply the changes Yoshiki made to Etoys 3.2 to license clean it for Etoys 4.0. This has been done in 0006988

 
(0012949 - 124 - 136 - 136 - 136 - 136 - 136)
matthewf
02-07-09 16:04
edited on: 02-09-09 23:39

I claimed some methods on the wiki, authors Adam Franco to Tom Morgan. I'll upload the changes later as relicense-mtf.1.cs

 
(0012950 - 54 - 66 - 66 - 66 - 66 - 66)
KenCausey
02-07-09 23:32
edited on: 02-09-09 23:41

I'll take Alejandro Reimondo through Henrik Gedenryd

 
(0012951 - 360 - 396 - 514 - 514 - 514 - 514)
KenCausey
02-07-09 23:55

I talked to Matthew and I wasn't happy tracking progress with each of us having separate copies of the files. So I'm trying instead for us all to share a wiki page

http://wiki.squeak.org/squeak/3680 [^]

Note lines that start with '!!!' are meta-comments, like claims of what methods we will work on.

I'd like for us to work with this and see how it goes.
 
(0012952 - 233 - 233 - 233 - 233 - 233 - 233)
KenCausey
02-08-09 00:00

By the way, if you are interested in helping with this I HIGHLY recommend coming to #squeak in irc.freenode.net and talking to us because we are still working out methodology as we go. My nick is kencausey and Matthew's is matthewf.
 
(0013128 - 417 - 447 - 599 - 599 - 599 - 599)
nicolas cellier
05-16-09 21:22

Since ScaledDecimal is ANSI, it is better to keep it in image.
See http://code.google.com/p/pharo/issues/detail?id=816 [^] for a MIT replacement.

I wrote it in a few minutes without watching any method of ScaledDecimal, and I think the result is quite different from previous implementation.

Rewriting is easy, because ScaledDecimal is essentially a special kind of Fraction with special decimal notation #printOn:
 
(0013645 - 30 - 30 - 30 - 30 - 30 - 30)
laza
04-08-10 10:43

Squeak 4.0 has been relicenced
 
(0013670 - 76 - 76 - 76 - 76 - 76 - 76)
KenCausey
04-08-10 17:21

Indeed, so I think we can close this since there has in fact been a release.
 

- Issue History
Date Modified Username Field Change
03-22-08 15:47 matthewf New Issue
03-22-08 15:47 matthewf Status new => assigned
03-22-08 15:47 matthewf Assigned To  => KenCausey
03-22-08 15:47 matthewf Assigned To KenCausey => matthewf
03-22-08 15:48 matthewf Relationship added parent of 0006988
03-22-08 16:50 matthewf Summary Issues for inclusion into Squeak 4.0 => Fixes for inclusion into Squeak 4.0
02-07-09 00:24 matthewf Note Added: 0012944
02-07-09 00:30 matthewf Priority normal => immediate
02-07-09 00:30 matthewf Severity feature => block
02-07-09 00:30 matthewf Summary Fixes for inclusion into Squeak 4.0 => Squeak still has code under SqueakL
02-07-09 00:30 matthewf Description Updated
02-07-09 00:30 matthewf Additional Information Updated
02-07-09 00:32 matthewf File Added: stillmissing-current.txt
02-07-09 00:33 matthewf File Added: stillmissing-historical.txt
02-07-09 00:34 matthewf File Added: stillmissing-sunit.txt
02-07-09 00:35 matthewf Description Updated
02-07-09 00:47 matthewf Note Edited: 0012944
02-07-09 03:58 matthewf Relationship added parent of 0007277
02-07-09 04:02 matthewf Relationship added parent of 0007278
02-07-09 04:05 matthewf Relationship added parent of 0007279
02-07-09 04:07 matthewf Relationship added parent of 0007280
02-07-09 04:09 matthewf File Deleted: stillmissing-current.txt
02-07-09 04:10 matthewf File Deleted: stillmissing-historical.txt
02-07-09 04:10 matthewf File Deleted: stillmissing-sunit.txt
02-07-09 04:15 matthewf Additional Information Updated
02-07-09 04:19 matthewf Additional Information Updated
02-07-09 04:19 matthewf Note Deleted: 0012944
02-07-09 04:27 matthewf Relationship added related to 0007281
02-07-09 04:47 matthewf File Added: fixedin-kenel.txt
02-07-09 04:47 matthewf File Added: stillmissing-kernel.txt
02-07-09 04:49 matthewf Note Added: 0012945
02-07-09 05:30 matthewf Description Updated
02-07-09 05:33 matthewf Note Edited: 0012945
02-07-09 05:44 matthewf Description Updated
02-07-09 05:44 matthewf Description Updated
02-07-09 05:46 matthewf Additional Information Updated
02-07-09 05:47 matthewf Note Edited: 0012945
02-07-09 16:04 matthewf Note Added: 0012949
02-07-09 16:09 matthewf Note Edited: 0012949
02-07-09 23:32 KenCausey Note Added: 0012950
02-07-09 23:33 KenCausey Note Edited: 0012950
02-07-09 23:55 KenCausey Note Added: 0012951
02-08-09 00:00 KenCausey Note Added: 0012952
02-09-09 20:43 matthewf Description Updated
02-09-09 20:44 matthewf Description Updated
02-09-09 20:54 KenCausey Description Updated
02-09-09 23:39 matthewf Note Edited: 0012949
02-09-09 23:41 KenCausey Note Edited: 0012950
05-16-09 21:22 nicolas cellier Note Added: 0013128
06-20-09 17:24 matthewf Description Updated
06-20-09 17:26 matthewf Description Updated
09-15-09 20:22 nicolas cellier File Added: KernelNumber-PharoLicenseCleanEffort-GabrielCotelli.st
04-08-10 10:43 laza Status assigned => resolved
04-08-10 10:43 laza Fixed in Version  => 4.0
04-08-10 10:43 laza Resolution open => no change required
04-08-10 10:43 laza Note Added: 0013645
04-08-10 17:21 KenCausey Status resolved => closed
04-08-10 17:21 KenCausey Note Added: 0013670


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
174 total queries executed.
66 unique queries executed.
Powered by Mantis Bugtracker