Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007003 [Squeak Packages] Nebraska major always 04-05-08 07:13 04-08-10 14:35
Reporter Keith_Hodges View Status public  
Assigned To
Priority normal Resolution open  
Status new  
Summary 0007003: Nebraska not working
Description Nebraska not working in 3.10
Additional Information
Attached Files  Picture 2.png [^] (208,225 bytes) 08-02-08 10:23
 Picture 3.png [^] (29,627 bytes) 08-02-08 10:24
 SqueakDebug.log [^] (2,793 bytes) 08-02-08 10:25

- Relationships

- Notes
(0012424 - 78 - 84 - 84 - 84 - 84 - 84)
edgardec
07-31-08 20:58

Ja !
Nebraka works, only have some Font issue I send to Yoshiki long time ago
 
(0012426 - 393 - 453 - 453 - 453 - 453 - 453)
wiz
08-01-08 03:04

Hi keith, Hi edgar.

Can you guys be more specific?

Keith, how can you get from a fresh 3.10.2 to a point where you can see your problem? Specifically what symptoms are you talking about?

Edgar, which of the font issues is this and why do you think it is causing Keith's problem.

Fixes depend on good observations and informational recipes for tracking the problems.

Cheers -Jer
 
(0012429 - 1833 - 2039 - 2039 - 2039 - 2039 - 2039)
edgardec
08-02-08 10:22

How to test Nebraska with only a computer
Take an .image and do a copy.
For Mac, also do a VM copy
Opens .image in Vm and .image copy in VM copy
In my case I have a Mini LAN with Windows XP, Simply Linux, PPC Mac
Tiger and Intel Mac Leopard.
Waiting iPod Vm for also have iPod connected
On both machines or Squeak copies go to Objects Flaps
Select Collaborative, drag Listener to World and click to raise
"antenna"
Select Badge, answer with different names like "Alfred" and "Bruce" :=)
You must see ip number like 192.168.1.2 and 192.168.1.3 in the two copies of Squeak on different machines
Go to Supplies and drag and drop a Ellipse on to question sign of Badge
If two copy is on the same computer, you send from the second to first
as you see in the attached picture
This part of Nebraska always, always, always works and never have any trouble.
Is the first Squeak experience I show to my students as my official task in UTN is about Networks with Tannenbaum book.
Things could go wild between different images , that's why my pict shows 3.10 and old messy 3.9 image I have.
Because if you have messy images and try to send some Morphs....
I do this between my computer and one student in his own house long time ago and all works as long you have nice ISP with transparent proxy.
But fails sending some compicated Morphs, but this is not Nebraska failure is SmartRefsStream failures we use to encode Morphs and causing headaches.
Now, maybe this is Keith issue.
Open Nebraska server on second computer, in this case my messy 3.9
Click on "S" of first computer and you have the attached walkback and pict
I send a solution to Yoshiki, who seems in charge of this kind of bug.

By the way, "Batman" is logged on FunSqueak 7 on the SimplyLinux computer, so I don't have a easy way to take picts and logs.
 
(0012430 - 89 - 89 - 89 - 89 - 89 - 89)
edgardec
08-02-08 10:26

When I have some time, dig my old for the solution once I do and send to Yoshiki for this
 

- Issue History
Date Modified Username Field Change
04-05-08 07:13 Keith_Hodges New Issue
07-31-08 20:58 edgardec Note Added: 0012424
08-01-08 03:04 wiz Note Added: 0012426
08-02-08 10:22 edgardec Note Added: 0012429
08-02-08 10:23 edgardec File Added: Picture 2.png
08-02-08 10:24 edgardec File Added: Picture 3.png
08-02-08 10:25 edgardec File Added: SqueakDebug.log
08-02-08 10:26 edgardec Note Added: 0012430
05-06-09 21:44 sabren Issue Monitored: sabren
04-08-10 14:35 laza Project Squeak => Squeak Packages


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
56 total queries executed.
37 unique queries executed.
Powered by Mantis Bugtracker