Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007035 [Squeak] ToDo minor always 05-09-08 04:24 01-07-09 17:02
Reporter KenCausey View Status public  
Assigned To edgardec
Priority immediate Resolution fixed  
Status closed   Product Version 3.10
Summary 0007035: Fix system version for 3.10.1
Description It turns out that if you ask 3.10-7159 for it's SystemVersion current it returns 3.10beta. This is minor and 3.10 is out the door but is low hanging fruit for a quick (say by May 26th) 3.10.1. Let's look for other things and add them as ToDo items.
Additional Information
Attached Files

- Relationships

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

related to 0006897closed KenCausey Retargeting an UpdatingMenuItem needs to consider the wording provider. 
related to 0006844closed KenCausey Bug with scrollbars for certain combination of preferences. 
related to 0006793closed KenCausey In sq 7158 The Object Tool and the Object Flap are out of sync. 
related to 0005309closed andreas [Bug][Fix] Under certain conditions returning from a MVC project will hang indefinitely. 
related to 0007045closed KenCausey RenderBugz tests revised to avoid extraneous timing issues. 
related to 0007057closed KenCausey [Fix] The test LangEnvBugs did not leave fonts the way they were. 
related to 0007060closed laza Delay>>timeoutSemaphore:afterMSecs: never signals semaphore 

- Notes
(0012057 - 274 - 274 - 274 - 274 - 274 - 274)
KenCausey
05-09-08 04:25

Note that if the current release team finds releasing a new version by May 26th (minor release version with easy/obvious fixes) impossible to do for personal reasons or whatever, please make that clear as soon as possible and I will take responsibility for making it happen.
 
(0012064 - 887 - 911 - 911 - 911 - 911 - 911)
KenCausey
05-09-08 20:02

OK, so this is easiest enough to fix (a little research needed but it doesn't amount to much more than a one-liner I suspect). But the real question is how to reduce the chances of this mistake in the future.

Test have been a priority for 3.10; this was an error, it seems reasonable to have a test for it. I can envision a sort of test for this, let's say one could be written and work properly. Such a test however is going to be read for the entire development process until right after the moment the process is considered done and the release switch is pushed. So is such a test helpful or simply disruptive.

It seems like there needs to be a sort of automated todo list to support this sort of thing separate from the other unit tests. It would also be run periodically but it would be understood (perhaps clearly marked) that certain tests are not expected to pass yet.
 
(0012067 - 118 - 118 - 118 - 240 - 240 - 240)
wiz
05-10-08 00:54

0006897 fixes a hole in the retargeting of updating menus. It fixes the wording source iff it is the same as the target.
 
(0012068 - 88 - 88 - 88 - 198 - 198 - 198)
wiz
05-10-08 00:59

0006844 fixes a problem with scrollbars by enforcing that unused menu buttons must be nil.
 
(0012069 - 367 - 391 - 391 - 505 - 505 - 505)
wiz
05-10-08 01:20

0006793 mentions that a janitoral task needs to occur to synchronize the objects flap with the object tool.

The catagory kadema is missing in the flap which has an (empty) StarSqueak catagory instead.

Doing something once to clear this up would be all that is needed to fix this. Having a script or method that does this for releases in the future would be gravy.
 
(0012072 - 271 - 301 - 301 - 440 - 440 - 440)
wiz
05-10-08 02:10

0005309 proposes a fix for isFontAvailable to correct the 3.10 fix I attempted when I knew less.

This is an **important** fix as what I did before broke things. This should have gotten into 3.10 final but did not.

the correct fix is:
fontAvailable-1204yo-wiz.1.cs
 
(0012104 - 294 - 318 - 318 - 428 - 428 - 428)
wiz
05-17-08 04:37

0007045 RenderBugz tests revised to avoid extraneous timing issues.

The test revisions reduce the time sensitivity of the test when run from the gui. Apparently gc's were occasionally causing things to time out.

Added a control test which will only fail due to the extraneous time factors.
 
(0012108 - 505 - 529 - 733 - 977 - 977 - 977)
KenCausey
05-18-08 18:11

0006897 clearly states that this issue is one that existed in 3.9 and since the focus for 3.10.1 is in correcting bugs new in 3.10, this fix is inappropriate for 3.10.1. However an update for this has already been added to the update stream

http://ftp.squeak.org/updates/7162UpdatingMenuItemMorph-target-M6897-wiz.1.cs [^]

and I'm even more strongly against making any changes to the update stream other than appending to it. So I will accept this as done and add any other comments I may have to 0006897.
 
(0012109 - 93 - 93 - 93 - 203 - 203 - 203)
KenCausey
05-18-08 19:14

0006844 also does not appear to be a new issue with 3.10 so should not be addressed for 3.10.1.
 
(0012110 - 125 - 125 - 125 - 239 - 239 - 239)
KenCausey
05-18-08 19:20

As far as I can tell 0006793 is in fact new to 3.10 and so appropriate for 3.10.1. This was addressed in update 7161 by Edgar.
 
(0012114 - 141 - 141 - 141 - 280 - 280 - 280)
KenCausey
05-18-08 19:43

0005309 is a bit confusing but it seems that at least the final part of it issued as update 7164 is specific to 3.10 so appropriate for 3.10.1.
 
(0012116 - 298 - 298 - 298 - 408 - 408 - 408)
KenCausey
05-18-08 19:52

0007045 addresses an issue I discovered with a test (RenderBugz) that appears to be new to 3.10. This doesn't seem to be a high priority issue though so while in one sense appropriate to 3.10.1 I believe it should be low on the todo list and only added after more important issues have been covered.
 
(0012122 - 418 - 454 - 454 - 571 - 571 - 571)
wiz
05-19-08 18:52

0007057 adds a tear down method to restore default fonts after running a test that changes fonts. This makes more repeatable subsequent passes of the test.

Ken on 7045, you are right in that it is not totally critical. But it will be important to prove all tests green and not having the upgrade will mean sporadic failures. In that sense it is essential.

Cheers,

Yours in curiosity and service, --Jerome Peace
 
(0012131 - 152 - 152 - 152 - 268 - 268 - 268)
KenCausey
05-20-08 22:38

0007060 points out a problem with a refactoring that occurred during 3.9 but was not actually used until 3.10. This might be worth harvesting for 3.10.1.
 
(0012151 - 181 - 181 - 181 - 181 - 181 - 181)
KenCausey
05-23-08 23:51

Edgar fixed the SystemVersion issue with update 7160. All the other issues mentioned in this notice deemed relevant to 3.10.1 have been harvested as noted in the individual issues.
 
(0012152 - 21 - 21 - 21 - 21 - 21 - 21)
KenCausey
05-23-08 23:52

just restoring status
 
(0012172 - 15 - 15 - 15 - 15 - 15 - 15)
KenCausey
05-26-08 18:33

Fixed in 3.10.1
 
(0012904 - 23 - 23 - 23 - 23 - 23 - 23)
KenCausey
01-07-09 17:02

Giving proper credit...
 

- Issue History
Date Modified Username Field Change
05-09-08 04:24 KenCausey New Issue
05-09-08 04:24 KenCausey Status new => assigned
05-09-08 04:24 KenCausey Assigned To  => RalphJohnson
05-09-08 04:25 KenCausey Note Added: 0012057
05-09-08 20:02 KenCausey Note Added: 0012064
05-10-08 00:54 wiz Note Added: 0012067
05-10-08 00:59 wiz Note Added: 0012068
05-10-08 01:20 wiz Note Added: 0012069
05-10-08 02:10 wiz Note Added: 0012072
05-17-08 04:37 wiz Note Added: 0012104
05-18-08 18:11 KenCausey Note Added: 0012108
05-18-08 19:14 KenCausey Note Added: 0012109
05-18-08 19:20 KenCausey Note Added: 0012110
05-18-08 19:43 KenCausey Note Added: 0012114
05-18-08 19:52 KenCausey Note Added: 0012116
05-19-08 18:52 wiz Note Added: 0012122
05-20-08 22:38 KenCausey Note Added: 0012131
05-20-08 22:47 KenCausey Relationship added related to 0006897
05-20-08 22:47 KenCausey Relationship added related to 0006844
05-20-08 22:47 KenCausey Relationship added related to 0006793
05-20-08 22:47 KenCausey Relationship added related to 0005309
05-20-08 22:48 KenCausey Relationship added related to 0007045
05-20-08 22:48 KenCausey Relationship added related to 0007057
05-20-08 22:48 KenCausey Relationship added related to 0007060
05-23-08 23:51 KenCausey Status assigned => resolved
05-23-08 23:51 KenCausey Fixed in Version  => 3.10
05-23-08 23:51 KenCausey Resolution open => fixed
05-23-08 23:51 KenCausey Note Added: 0012151
05-23-08 23:52 KenCausey Status resolved => assigned
05-23-08 23:52 KenCausey Assigned To RalphJohnson => KenCausey
05-23-08 23:52 KenCausey Status assigned => resolved
05-23-08 23:52 KenCausey Note Added: 0012152
05-26-08 18:33 KenCausey Status resolved => closed
05-26-08 18:33 KenCausey Note Added: 0012172
01-07-09 17:02 KenCausey Status closed => assigned
01-07-09 17:02 KenCausey Assigned To KenCausey => edgardec
01-07-09 17:02 KenCausey Status assigned => closed
01-07-09 17:02 KenCausey Note Added: 0012904


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
148 total queries executed.
86 unique queries executed.
Powered by Mantis Bugtracker