Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007060 [Squeak] Kernel major always 05-20-08 21:37 04-18-10 22:04
Reporter GazzaGuru View Status public  
Assigned To laza
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0007060: Delay>>timeoutSemaphore:afterMSecs: never signals semaphore
Description The method mentioned in the summary seems broken.
Test code described below.
Fix included (MIT license, of course...).
Additional Information |s|
s := Semaphore new.
Delay timeoutSemaphore: s afterMSecs: 2000.
s wait
Attached Files  DelaySemaphoreFix.1.cs [^] (922 bytes) 05-20-08 21:37

- Relationships
related to 0006834closed laza Delay class>>timeoutSemaphore:afterMSecs: doesn't. 
related to 0007035closed edgardec Fix system version for 3.10.1 

- Notes
(0012127 - 45 - 45 - 45 - 45 - 45 - 45)
GazzaGuru
05-20-08 21:39

Class side method, in 3.9 and 3.10, at least.
 
(0012129 - 156 - 156 - 156 - 156 - 156 - 156)
KenCausey
05-20-08 22:34

The root of the problem is that the new version (as of 3.9) of this method does not use the passed semaphore. There were no callers in 3.9 but are in 3.10.
 
(0012130 - 201 - 201 - 201 - 201 - 201 - 201)
KenCausey
05-20-08 22:37

The implementation in 3.8 looks much like Gary's submission except there is also a check on the time specified to insure it is non-negative. Perhaps we should simply revert to the 3.8 implementation?
 
(0012146 - 171 - 171 - 171 - 171 - 171 - 171)
KenCausey
05-23-08 20:30

While this should be harvested, I'm not going to harvest it for 3.10.1 because it addresses an issue that existed in 3.9 and we need 3.10.1 to focus on new issues in 3.10.
 

- Issue History
Date Modified Username Field Change
05-20-08 21:37 GazzaGuru New Issue
05-20-08 21:37 GazzaGuru Status new => assigned
05-20-08 21:37 GazzaGuru Assigned To  => KenCausey
05-20-08 21:37 GazzaGuru File Added: DelaySemaphoreFix.1.cs
05-20-08 21:39 GazzaGuru Note Added: 0012127
05-20-08 21:45 KenCausey Assigned To KenCausey =>
05-20-08 21:45 KenCausey Status assigned => new
05-20-08 21:45 KenCausey Category Any => Kernel
05-20-08 22:34 KenCausey Note Added: 0012129
05-20-08 22:37 KenCausey Note Added: 0012130
05-20-08 22:48 KenCausey Relationship added related to 0007035
05-23-08 20:30 KenCausey Note Added: 0012146
05-29-08 15:14 KenCausey Relationship added related to 0006834
10-07-09 04:59 laza Status new => assigned
10-07-09 04:59 laza Assigned To  => laza
10-07-09 05:00 laza Status assigned => resolved
10-07-09 05:00 laza Fixed in Version  => trunk
10-07-09 05:00 laza Resolution open => fixed
04-18-10 22:04 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
69 total queries executed.
45 unique queries executed.
Powered by Mantis Bugtracker