Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007075 [Squeak] Monticello major always 05-30-08 23:36 04-18-10 22:06
Reporter hfm View Status public  
Assigned To avi
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0007075: Monticello Configuration Maps do not open in sq3.9.1-7075dev08.05.2
Description First, I do not use Universes Browser because I'm using latest version of Magma which is not listed in the UB.

How to reproduce this problem:

-Download sq3.9.1-7075dev08.05.2.zip from https://gforge.inria.fr/frs/?group_id=1299 [^]

-Add this repository in the Monticello Browser
MCHttpRepository
    location: 'http://www.squeaksource.com/MagmaTester' [^]
    user: ''
    password: ''

-Scroll down to latest Monticello Configuration Map release. (At time of this writing should be r41Beta2)

-Select the mcm file in the right pane

-Error: My subclass should have overridden #loadVersionInfo

(See my previous bug report for working versions of Monticello, Monticello Configurarion and PackageInfo)
Additional Information
Attached Files

- Relationships

- Notes
(0012238 - 115 - 127 - 267 - 267 - 267 - 267)
Keith_Hodges
06-02-08 08:19

Best solution for this is to run the LevelPlayingField Script

see: http://installer.pbwiki.com/LevelPlayingField [^]
 
(0012240 - 1162 - 1348 - 1508 - 1508 - 1508 - 1508)
hfm
06-02-08 16:18

Hello Keith. I run into several problems using the Installer from the page at http://installer.pbwiki.com/LevelPlayingField-Squeak3:9 [^]

1) I tried the following way
(HTTPSocket httpGet: 'installer.pbwiki.com/f/LPF.st') readStream fileIn.
SmalltalkImage saveAs: 'new.image'.

(BTW this image do not understand #saveAs:)

but the #fileIn fails with MessageNotUnderstood: FlexibleVocabulariesInfo>>includesSystemCategory:

2) Below in the page there's another way, so I selected too this line

Installer install:'LevelPlayingField-Monticello15'.

I received a MessageNotUnderstood: Installer>>installSilently.

Maybe this is another bug concerning the Damien's image. The Installer installed version is Installer-Core-kph.187 so maybe Damien should upgrade Installer to remove this problem. I upgraded his image to latest Installer-Core-kph from SqueakSource.

3) Run again this line

Installer install:'LevelPlayingField-Monticello15'.

and again another MNU:

MessageNotUnderstood: PackageInfo>>includesSystemCategory:

I am missing something?

Correction: I'm using sq3.9.1-7075web08.05.2 but I suspect same happens in the dev image.
 
(0012243 - 130 - 154 - 154 - 154 - 154 - 154)
Keith_Hodges
06-02-08 17:49

You could join us in irc #squeak to go over this.

Your best bet is probably.

Installer upgrade install: 'LevelPlayingField'.
 
(0012244 - 134 - 140 - 140 - 140 - 140 - 140)
hfm
06-02-08 18:03

Thanks Keith. I solved installing latest MC 1.5 from the Universes Browser (Enhaced). I will try your tip in the backup later.
Cheers
 

- Issue History
Date Modified Username Field Change
05-30-08 23:36 hfm New Issue
05-30-08 23:36 hfm Status new => assigned
05-30-08 23:36 hfm Assigned To  => avi
06-02-08 08:19 Keith_Hodges Note Added: 0012238
06-02-08 16:18 hfm Note Added: 0012240
06-02-08 17:49 Keith_Hodges Note Added: 0012243
06-02-08 18:03 hfm Note Added: 0012244
06-07-08 02:39 Keith_Hodges Status assigned => resolved
06-07-08 02:39 Keith_Hodges Resolution open => fixed
04-18-10 22:06 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
51 total queries executed.
38 unique queries executed.
Powered by Mantis Bugtracker