Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007076 [Squeak] Janitorial major always 05-31-08 03:18 01-07-09 18:08
Reporter wiz View Status public  
Assigned To KenCausey
Priority urgent Resolution fixed  
Status closed   Product Version 3.10.1
Summary 0007076: [tests] The revision (5-29) of the release still leaves problems and 5 classes with no category in system
Description In a fresh 3.10.1

run the uploaded tests.
at least one will fail.

click on the fix code
 then run the up loaded tests again.

one test now runs but the other will break.

See: 0007070


Additional Information The fixing code removes the five substantial classes from the catagory but not from the system.

The classes will not show up in a browser but are still in the Smalltalk dictionary and so included in #allClasses.

If anything assumes there will be a catagory for each class it will break.

The final steps of the release seem to have been done in a much more complicated way than needed.

Updating via the update stream from 7160-7175 will give an image that passes both tests.
Then all that would be needed is a cs with a postscript to condense changes.

Sometimes the last bug is a difficult one to remove. I encourage the release team to take whatever effort to get this right.
Squeaks reputation is at stake.

Yours in service and curiosity, --Jerome Peace

Attached Files  M7076ReleaseTests-wiz.1.cs [^] (1,531 bytes) 05-31-08 03:37

- Relationships
parent of 0007070closed KenCausey Browser category Morphic-CandidatesForGo contains missing classes 
related to 0007066assigned RalphJohnson Fixes ready to go into the next squeak alpha release (3.11 ???) 

- Notes
(0012232 - 420 - 529 - 529 - 645 - 645 - 645)
wiz
05-31-08 03:42

 M7076ReleaseTests-wiz.1.cs
adds two tests to ReleaseTests

both pass in a version of 7175 from the updatestream.

in the 5-29 revision of 7175 the #testSystemCategoryClasses
 fails before the "click fix"

and #testClassesSystemCategory
fails after the "click fix"

Yours in service and curiosity, --Jerome Peace.

This supercedes my suggested fix in 0007070
and fixes some of my creative spelling. :-)
 
(0012233 - 194 - 236 - 236 - 236 - 236 - 236)
wiz
05-31-08 03:46

Reminder sent to: edgardec, KenCausey

Hi Ken, Hi Edgar,


I think you need to make these tests work in a corrected release of 3.10.1

Thanks for you attention to these matters.

Yours in service and curiosity, --Jerome Peace
 
(0012235 - 1619 - 2081 - 2283 - 2283 - 2283 - 2283)
wiz
06-02-08 05:48

Ha. commenting out a section was all that was needed.
If the classes are not removed individually then
removing the category will delete the classes as well.
Which is what is wanted.

See also:
http://lists.squeakfoundation.org/pipermail/squeak-dev/2008-June/129026.html [^]

my reply to Klaus.

I think there might be some more issues with the release.
Ken: how did you actually complete things?
How was the phantom category reintroduced?
Did the process risk other things coming back as well?

How similar can we prove this image to the image genned up
by updating a 7160 from the update stream?
How would we build a test to see if the similarity is there or not?
E.g. (the number of classes should be the same. ditto the number of compiled methods. What else would be worth checking?)

Can we check method timestamps for equality between the two images?






 
Anyway the corrected code is below.
I could not figure how to get the click action to work again once I edited it.




SystemOrganization categories do: [:catName |
  (SystemOrganization listAtCategoryNamed: catName)
    do: [:className |
      (Smalltalk includesKey: className) ifFalse: [
        Transcript show: 'Removing ', className printString, String cr.
         SystemOrganization removeElement: className]]].

SystemOrganization classify: #ClassRepresentativeMorph under: 'EToys-Scripting'.

"#(CommandTilesMorph DrawErrorMorph PhraseWrapperMorph ViewerEntry ViewerRow)
    do: [ :symbol | SystemOrganization removeElement: symbol ]."

SystemOrganization removeSystemCategory: 'Morphic-CandidatesForGo'.
 
(0012257 - 138 - 138 - 138 - 138 - 138 - 138)
KenCausey
06-05-08 18:53

These tests have been added to the update stream for 3.10.2beta as update 7177, an improved fix for the problem is intended as update 7178
 
(0012258 - 113 - 113 - 113 - 113 - 113 - 113)
KenCausey
06-05-08 19:24

A proper fix for this which passes the tests attached and included in update 7177 has been issued as update 7178.
 
(0012906 - 56 - 56 - 56 - 56 - 56 - 56)
KenCausey
01-07-09 18:08

Harvested as update 7177 and released with Squeak 3.10.2
 

- Issue History
Date Modified Username Field Change
05-31-08 03:18 wiz New Issue
05-31-08 03:18 wiz File Added: ReleaseTest-te...temCatagory.st
05-31-08 03:20 wiz File Added: ReleaseTest-te...goryClasses.st
05-31-08 03:36 wiz Relationship added parent of 0007070
05-31-08 03:37 wiz File Added: M7076ReleaseTests-wiz.1.cs
05-31-08 03:37 wiz File Deleted: ReleaseTest-te...temCatagory.st
05-31-08 03:37 wiz File Deleted: ReleaseTest-te...goryClasses.st
05-31-08 03:42 wiz Note Added: 0012232
05-31-08 03:46 wiz Issue Monitored: edgardec
05-31-08 03:46 wiz Issue Monitored: KenCausey
05-31-08 03:46 wiz Note Added: 0012233
05-31-08 19:06 KenCausey Status new => assigned
05-31-08 19:06 KenCausey Assigned To  => KenCausey
06-02-08 05:48 wiz Note Added: 0012235
06-02-08 18:37 wiz Relationship added related to 0007066
06-05-08 18:53 KenCausey Note Added: 0012257
06-05-08 19:24 KenCausey Status assigned => resolved
06-05-08 19:24 KenCausey Fixed in Version  => 3.10.2
06-05-08 19:24 KenCausey Resolution open => fixed
06-05-08 19:24 KenCausey Note Added: 0012258
01-07-09 18:08 KenCausey Status resolved => closed
01-07-09 18:08 KenCausey Note Added: 0012906


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
83 total queries executed.
47 unique queries executed.
Powered by Mantis Bugtracker