Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007103 [Squeak] VM major always 06-25-08 08:56 04-13-14 12:38
Reporter jredrejo View Status public  
Assigned To tim
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0007103: Playing sounds in linux 64 bits causes a vm segmentation fault
Description Whenever a recorded sound is played, or using the etoys tile "sounds", or trying to use some of the multimedia reproductors, the vm always segfaults in linux 64 bits.
Additional Information This bug has also been reported on Debian:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=487871 [^]
Attached Files  SoundPlugin-64bit-dtl.1.cs [^] (2,771 bytes) 04-27-09 00:23
 SoundPlugin64PlatformDiffs-unix-dtl.zip [^] (5,956 bytes) 04-27-09 01:36

- Relationships

- Notes
(0013093 - 460 - 484 - 484 - 484 - 484 - 484)
lewis
04-27-09 00:27
edited on: 04-27-09 11:08

I uploaded the fix for SoundPlugin and the platform diffs to fix this problem for Unix platforms. Some additional (straightforward) updates will be needed for Windows and Mac. I tested sound output on ALSA and OSS on Linux, other Unix vm-sound-whatever are updated but not tested. Sound recording probably works, but I don't have a microphone handy to verify.

With these changes, sound works on 64-bit Linux ALSA and OSS for both 32-bit and 64-bit images.

 
(0013095 - 651 - 768 - 768 - 768 - 768 - 768)
jredrejo
04-27-09 16:13

I have compiled and tested this patches (the diff had a small typo,a comma is missed in the NAS file), but sound still segfaults.
Tested in Debian Lenny, using alsa:
/opt/src/squeak/vm/debian

Segmentation fault

16643640 [] in >playLoop
16643732 [] in Semaphore>critical:
16643456 BlockContext>ensure:
16643272 Semaphore>critical:
16610756 >playLoop
16610572 [] in >startPlayerProcessBufferSize:rate:stereo:sound:
16610664 [] in BlockContext>newProcess
/usr/bin/squeak: line 277: 14241 Abortado $VM


I guess the patch is in the right way, but there're still some parts in the code that must be made 64 bits compatible.
 
(0013107 - 490 - 526 - 918 - 918 - 918 - 918)
lewis
05-02-09 14:25

Note, Josť confirmed on vm-dev that sound is now working on his 64-bit Linux:
http://lists.squeakfoundation.org/pipermail/vm-dev/2009-April/002597.html [^]

The problem in the above note was due to not having regenerated the plugin from VMMaker.

Josť also mentions a typo in my NAS diff. I think the fix was attached to his post here (but I can't get at the attachment at the moment, need to sort this out later):
http://lists.squeakfoundation.org/pipermail/vm-dev/2009-April/002595.html [^]
 
(0013108 - 567 - 648 - 896 - 896 - 896 - 896)
jredrejo
05-02-09 14:37

As lewis says, the bug seems to be fixed with the patches he attached here, so, this report can be closed.

About the typo in his patches, the problem is in the patch for
 squeak-vm-3.10.4/platforms/unix/vm-sound-NAS/sqUnixSoundNAS.c

The line:
static sqInt bytesAvail;
didn't have the ending ";" .
Appart from this, the patches work perfectly. I've transformed these patches in an unified format that can be downloaded from:
http://svn.debian.org/viewsvn/pkg-squeak/packages/squeak-vm/trunk/debian/patches/sound64bits.dpatch [^]

Thanks to lewis for his work.
 
(0013462 - 206 - 206 - 206 - 206 - 206 - 206)
lewis
01-11-10 22:47

SoundPlugin-64bit-dtl.1.cs has been added to VMMaker-dtl.156 on SqueakSource. The matching platforms changes will be applied over the next couple of weeks, after which sound should work on future VM builds.
 
(0014019 - 34 - 34 - 34 - 34 - 34 - 34)
lewis
01-09-11 23:45

Should be fixed in all current VMs
 

- Issue History
Date Modified Username Field Change
06-25-08 08:56 jredrejo New Issue
06-25-08 08:56 jredrejo Status new => assigned
06-25-08 08:56 jredrejo Assigned To  => tim
06-30-08 12:57 smithjonesetal Issue Monitored: smithjonesetal
11-19-08 11:40 lewis Issue Monitored: lewis
04-27-09 00:23 lewis File Added: SoundPlugin-64bit-dtl.1.cs
04-27-09 00:24 lewis File Added: SoundPlugin64PlatformDiffs-unix-dtl.zip
04-27-09 00:27 lewis Note Added: 0013093
04-27-09 01:35 lewis File Deleted: SoundPlugin64PlatformDiffs-unix-dtl.zip
04-27-09 01:36 lewis File Added: SoundPlugin64PlatformDiffs-unix-dtl.zip
04-27-09 10:37 lewis Note Added: 0013094
04-27-09 10:38 lewis Note Edited: 0013094
04-27-09 11:03 lewis Note Deleted: 0013094
04-27-09 11:08 lewis Note Edited: 0013093
04-27-09 16:13 jredrejo Note Added: 0013095
05-02-09 14:25 lewis Note Added: 0013107
05-02-09 14:37 jredrejo Note Added: 0013108
01-11-10 22:47 lewis Note Added: 0013462
01-09-11 23:45 lewis Status assigned => resolved
01-09-11 23:45 lewis Resolution open => fixed
01-09-11 23:45 lewis Note Added: 0014019
04-13-14 12:38 lewis Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
83 total queries executed.
43 unique queries executed.
Powered by Mantis Bugtracker