Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007241 [Squeak] Graphics tweak always 12-07-08 01:39 06-25-10 05:33
Reporter timj View Status public  
Assigned To andreas
Priority normal Resolution fixed  
Status testing   Product Version 3.10.2
Summary 0007241: BDFFontReader doesn't call #initialize
Description found originally reported to mailing list in 2007: http://lists.squeakfoundation.org/pipermail/squeak-dev/2007-September/121011.html [^]

BDFFontReader class has a #new which calls #basicNew. The problem is that new instances of BDFFontReader must call #initialize and it is not being called. I propose we remove the class-side #new method.
Additional Information Attached a changeset to remove BDFFontReader class>>#new
Attached Files  BDFFontReader class.tcj.1.cs [^] (138 bytes) 12-07-08 01:39

- Relationships
child of 0006570assigned tim A Mother for font and font test problems 

- Notes
(0012836 - 911 - 1025 - 1025 - 1025 - 1025 - 1025)
wiz
12-07-08 06:36

Hi Tim,

Thanks for taking the effort to follow thru with a report and fix for the bug.

To help get the bug Permanently fixed. It would be good to have a simple sunit test that fails before the patch and passes after.

In this case it would consist of getting an new BDFFontReader whatsit and then asserting that it is properly initialized.

Having the test helps prevent the reversion of the bug in the future.
I mean think about it. Someone must have gone out of their way to create the bug in the first place.
Which means they thought they had a reason.
And no one reading this report knows the reason (or they would have said).
So someone might revert the bug and the test would catch them.
If it exists.

Anyway I leave it to you, but I recommend it as a good learning exercise and a good contribution to the stability of squeak.

Cheers.

Yours in curiosity and service, --Jerome Peace
 
(0012967 - 87 - 119 - 119 - 119 - 119 - 119)
KenCausey
02-15-09 05:26

"fix begin"
Installer mantis bug: 7241 fix: 'BDFFontReader class.tcj.1.cs'.
"fix end"
 
(0013823 - 266 - 290 - 290 - 290 - 290 - 290)
dram
06-25-10 05:33

It shows that this bug was fixed in 3.11. But BDFFontReader class>>new can still be found at 4.1, and also in 4.2-10160-alpha.

I can confirm that without removing class>>new, BDFFontReader can not work properly. So may someone integrate this changeset into trunk?
 

- Issue History
Date Modified Username Field Change
12-07-08 01:39 timj New Issue
12-07-08 01:39 timj Status new => assigned
12-07-08 01:39 timj Assigned To  => andreas
12-07-08 01:40 timj File Added: BDFFontReader class.tcj.1.cs
12-07-08 01:40 timj Issue Monitored: timj
12-07-08 02:08 lewis Issue Monitored: lewis
12-07-08 04:57 Keith_Hodges Note Added: 0012835
12-07-08 05:31 Keith_Hodges Relationship added child of 0006570
12-07-08 06:36 wiz Note Added: 0012836
01-10-09 02:13 Keith_Hodges Status assigned => pending
01-10-09 02:59 Keith_Hodges Status pending => testing
01-10-09 03:40 Keith_Hodges Status testing => resolved
01-10-09 03:40 Keith_Hodges Fixed in Version  => 3.11
01-10-09 03:40 Keith_Hodges Resolution open => fixed
01-10-09 03:41 Keith_Hodges Status resolved => testing
02-15-09 05:26 KenCausey Note Added: 0012967
02-15-09 05:27 Keith_Hodges Note Deleted: 0012835
06-25-10 05:33 dram Note Added: 0013823


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
71 total queries executed.
44 unique queries executed.
Powered by Mantis Bugtracker