Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007244 [Squeak] Kernel major always 12-12-08 03:03 03-28-09 01:02
Reporter Keith_Hodges View Status public  
Assigned To
Priority high Resolution reopened  
Status feedback   Product Version 3.10.2
Summary 0007244: Image cleanUp methods
Description Methods implementing

SmalltalkImage current cleanUpAll.
 &
SmalltalkImage current freeSpace.
Additional Information
Attached Files  CleanUps.1.cs [^] (72,996 bytes) 12-12-08 03:03
 CleanUps.2.cs [^] (72,595 bytes) 12-15-08 21:58
 M7244-CleanUps.1.cs [^] (69,722 bytes) 12-16-08 12:40
 M7244-CleanUps.2.cs [^] (44,594 bytes) 02-12-09 17:40
 M7244-CleanUps.3.cs [^] (49,181 bytes) 02-12-09 23:50
 M7244-CleanUps.4.cs [^] (48,265 bytes) 02-20-09 06:21
 M7244-CleanUps.5.cs [^] (49,105 bytes) 03-09-09 17:50

- Relationships
related to 0006180closed Keith_Hodges Use memoryHogs and freeSomeSpace 

- Notes
(0012844 - 80 - 124 - 124 - 124 - 124 - 124)
Keith_Hodges
12-12-08 03:05
edited on: 02-21-09 02:03

"fix begin"
Installer mantis bug: 7244 fix: 'M7244-CleanUps.4.cs'.
"fix end"

 
(0012850 - 309 - 363 - 363 - 363 - 363 - 363)
Keith_Hodges
12-15-08 21:56
edited on: 02-20-09 06:19

CleanUps.2.cs - adds cleanUpAllExcept: aListOfClassNames
M7244-CleanUps.1.cs - fix to cleanUpAllExcept
M7244-CleanUps.2.cs - lots more from John
M7244-CleanUps.3.cs - May load into 3.9
M7244-CleanUps.4.cs - Ensure that initials dialog isn't needed


Fix intended for 3.10.2, included in 3.10.2-build

 
(0012960 - 54 - 54 - 54 - 54 - 54 - 54)
Keith_Hodges
02-12-09 23:41

Received complaint that this fix doesnt load in to 3.9
 
(0013029 - 188 - 244 - 244 - 244 - 244 - 244)
matthewf
03-09-09 17:52
edited on: 03-09-09 17:52

added another cleanup method to Class freeSomeSpace: assert: [self superclass subclasses includes: self]

"fix begin"
Installer mantis bug: 7244 fix: 'M7244-CleanUps.5.cs'.
"fix end"

 
(0013030 - 341 - 395 - 395 - 395 - 395 - 395)
Keith_Hodges
03-10-09 01:14
edited on: 03-28-09 01:01

There appears to be a #cleanUp method which prompts for author initials. I havent tracked down which one yet.

The cleanUp of PaintboxMorph is too aggressive it doesn't recover, an simple #initialize is required.

add: Socket cleanUp ^ Socket deadServer: ''.

add: ScriptingSystem reclaimSpace.
(?) add: Smalltalk reclaimDependents.

 

- Issue History
Date Modified Username Field Change
12-12-08 03:03 Keith_Hodges New Issue
12-12-08 03:03 Keith_Hodges File Added: CleanUps.1.cs
12-12-08 03:05 Keith_Hodges Note Added: 0012844
12-15-08 21:55 Keith_Hodges File Added: CleanUps.2.cs
12-15-08 21:55 Keith_Hodges Note Edited: 0012844
12-15-08 21:56 Keith_Hodges Note Added: 0012850
12-15-08 21:58 Keith_Hodges File Deleted: CleanUps.2.cs
12-15-08 21:58 Keith_Hodges File Added: CleanUps.2.cs
12-15-08 21:59 Keith_Hodges Note Edited: 0012850
12-16-08 12:40 Keith_Hodges File Added: M7244-CleanUps.1.cs
12-16-08 12:41 Keith_Hodges Note Edited: 0012844
12-16-08 12:41 Keith_Hodges Note Edited: 0012850
12-16-08 18:54 Keith_Hodges Status new => confirmed
12-16-08 18:54 Keith_Hodges Fixed in Version  => 3.10.2bc
01-09-09 23:31 Keith_Hodges Status confirmed => resolved
01-10-09 02:11 Keith_Hodges Relationship added related to 0006180
02-12-09 17:40 Keith_Hodges File Added: M7244-CleanUps.2.cs
02-12-09 17:40 Keith_Hodges Note Edited: 0012844
02-12-09 17:41 Keith_Hodges Note Edited: 0012850
02-12-09 23:41 Keith_Hodges Note Added: 0012960
02-12-09 23:42 Keith_Hodges File Added: M7244-CleanUps.3.cs
02-12-09 23:42 Keith_Hodges Note Edited: 0012844
02-12-09 23:43 Keith_Hodges Note Edited: 0012850
02-12-09 23:50 Keith_Hodges File Deleted: M7244-CleanUps.3.cs
02-12-09 23:50 Keith_Hodges File Added: M7244-CleanUps.3.cs
02-16-09 00:20 KevinKelley Issue Monitored: KevinKelley
02-20-09 06:19 Keith_Hodges Note Edited: 0012850
02-20-09 06:21 Keith_Hodges File Added: M7244-CleanUps.4.cs
02-21-09 02:03 Keith_Hodges Note Edited: 0012844
03-09-09 16:16 matthewf Issue Monitored: matthewf
03-09-09 17:50 matthewf File Added: M7244-CleanUps.5.cs
03-09-09 17:52 matthewf Note Added: 0013029
03-09-09 17:52 matthewf Note Edited: 0013029
03-10-09 01:14 Keith_Hodges Note Added: 0013030
03-28-09 01:01 Keith_Hodges Note Edited: 0013030
03-28-09 01:02 Keith_Hodges Status resolved => feedback
03-28-09 01:02 Keith_Hodges Resolution open => reopened


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
121 total queries executed.
41 unique queries executed.
Powered by Mantis Bugtracker