Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007248 [Squeak] Graphics minor always 12-18-08 23:49 09-30-13 22:51
Reporter timj View Status public  
Assigned To andreas
Priority normal Resolution fixed  
Status closed   Product Version 3.10.2
Summary 0007248: TextAnchor breaks Paragraph parsing process
Description Changes made to TextAnchor in 3.9 broke it (ScriptLoader>>#script31). In Squeak 3.2, TextAnchor>># was specifically meant to be a noop. In 3.9 and 3.10, TextAnchor implements code which interrupts processes already working in the Paragraph render tree, and causes a DNU. I propose that we back off from the change and return TextAnchor to its original functionality, which is to do nothing.
Additional Information The only code in the base image which uses TextAnchor is BadgeMorph. BadgeMorph does not work with changes to TextAnchor in 3.9 and 3.10. With this fix, it works again as it did in 3.8.
Attached Files  TextAnchor-emphasizeScanner.st [^] (421 bytes) 12-18-08 23:49
 M7248-TextAnchor-emphasizeScanner.st [^] (395 bytes) 12-19-08 00:06
 TextAnchorM7248Test.st [^] (567 bytes) 12-19-08 00:08

- Relationships

- Notes
(0012871 - 484 - 520 - 520 - 520 - 520 - 520)
timj
12-18-08 23:51

The description field should read:

Changes made to TextAnchor in 3.9 broke it (ScriptLoader>>#script31). In Squeak 3.2, TextAnchor>>#emphasizeScanner was specifically meant to be a noop. In 3.9 and 3.10, TextAnchor>>#emphasizeScanner implements code which interrupts processes already working in the Paragraph render tree, and causes a DNU. I propose that we back off from the change and return TextAnchor>>#emphasizeScanner to its original functionality, which is to do nothing.
 
(0012872 - 88 - 88 - 88 - 88 - 88 - 88)
timj
12-19-08 00:07

Please ignore the first attachment. It uses #shouldNotImplement which is totally wrong!
 
(0014455 - 119 - 125 - 125 - 125 - 125 - 125)
tim
09-30-13 22:51

This seems to be resolved; TextAnchor code passes its tests and all looks ok.
No idea when it was actually sorted out.
 

- Issue History
Date Modified Username Field Change
12-18-08 23:49 timj New Issue
12-18-08 23:49 timj Status new => assigned
12-18-08 23:49 timj Assigned To  => andreas
12-18-08 23:49 timj File Added: TextAnchor-emphasizeScanner.st
12-18-08 23:49 timj Issue Monitored: timj
12-18-08 23:51 timj Note Added: 0012871
12-19-08 00:06 timj File Added: M7248-TextAnchor-emphasizeScanner.st
12-19-08 00:07 timj Note Added: 0012872
12-19-08 00:08 timj File Added: TextAnchorM7248Test.st
09-30-13 22:51 tim Status assigned => resolved
09-30-13 22:51 tim Fixed in Version  => 4.4
09-30-13 22:51 tim Resolution open => fixed
09-30-13 22:51 tim Note Added: 0014455
09-30-13 22:51 tim Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
55 total queries executed.
36 unique queries executed.
Powered by Mantis Bugtracker