Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000728 [Squeak] Kernel minor always 12-26-04 20:28 01-07-05 20:27
Reporter tim View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.8
Summary 0000728: Yet another AcornFileDirectory naming fix
Description RISC OS has a moderately bewildering collection of file naming rules including quite a few characters that are not permitted and at least one (space char) that is only permitted as a 'hard-space' character 160.
Since the simple excision of bad characters isn't enough to cope with this I've changed th algorithm to use a map from asciiValue to correct char or nil. Nils are left out of the corrected filename, otherwise the mapped character is used.

There is a nsaty complication because of the sick, twisted, demented and thoroughly innefficient way filenames are misused - a filename thathas bee ntested and corrected may get passed through the correction code at least twice, so the mapping needs to pass through any characters that are the result of mappings... yuck. We need to fix this.
Additional Information Since this is a RISC OS only matter, I claim my usual privilege of accepting this code immediately.
Attached Files  AcornFDcheckName-75.1.cs [^] (2,412 bytes) 12-26-04 20:28

- Relationships

- Notes
(0000967 - 84 - 84 - 84 - 84 - 84 - 84)
tim
12-26-04 20:31

Resolved by attached file. Affects RISC OS only. Add to updates any time convenient.
 
(0001020 - 26 - 26 - 26 - 26 - 26 - 26)
bert
01-07-05 20:27

6545AcornFDcheckName-75.cs
 

- Issue History
Date Modified Username Field Change
12-26-04 20:28 tim New Issue
12-26-04 20:28 tim File Added: AcornFDcheckName-75.1.cs
12-26-04 20:31 tim Status new => resolved
12-26-04 20:31 tim Resolution open => fixed
12-26-04 20:31 tim Assigned To  => tim
12-26-04 20:31 tim Note Added: 0000967
12-26-04 20:31 tim Assigned To tim =>
01-07-05 20:27 bert Status resolved => closed
01-07-05 20:27 bert Note Added: 0001020
01-07-05 20:27 bert Fixed in Version  => 3.8


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
44 total queries executed.
33 unique queries executed.
Powered by Mantis Bugtracker