Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007286 [Squeak] System major always 02-15-09 17:43 04-18-10 22:04
Reporter Keith_Hodges View Status public  
Assigned To lewis
Priority normal Resolution fixed  
Status closed   Product Version 3.11
Summary 0007286: SerialPlugin doesn't handle arbitrary nodes names (image fixes)
Description A quick summary of the issue: today, you can open a serial port in Squeak with "SerialPort new openPort:portNum.". Eg,for portNum = 1, it would map to COM1 under Windows and /dev/ttyS1 under Linux.
That's fine, except that recent Linux kernels don't mount most serial
devices on /dev/ttySxx, but on more specific nodes, like /dev/ttyACMxx
for modems, /dev/ttyUSBxx for certain USB->COM converters, etc.

To circumvent it, I modified the UNIX version of the Serial Port plugin to accept either port numbers or arbitrary paths. I modified
SqueakPlugin.c to introduce new primitive calls (plus their
corresponding "exports" declaration), namely:
EXPORT(sqInt) primitiveSerialPortCloseByName(void);
EXPORT(sqInt) primitiveSerialPortOpenByName(void);
EXPORT(sqInt) primitiveSerialPortReadByName(void);
EXPORT(sqInt) primitiveSerialPortWriteByName(void);

The modifications introduced by the attached patch should be transparent for all the existing code base. New code can access the serial ports either with a port number or with the node path using the same Squeak messages: SerialPort openPort:'/dev/ttyUSB0'.
Additional Information
Attached Files  M7286-SerialPortManagingNamedNodes-Sk.1.cs.gz [^] (1,315 bytes) 02-15-09 17:47

- Relationships
related to 0007266closed tim SerialPlugin doesn't handle arbitrary nodes names 

- Notes
(0012971 - 104 - 136 - 136 - 136 - 136 - 136)
Keith_Hodges
02-15-09 17:46

"fix begin"
Installer mantis bug: 7266 fix: 'M7266-SerialPortManagingNamedNodes-Sk.1.cs.gz'.
"fix end"
 
(0013243 - 337 - 337 - 337 - 337 - 337 - 337)
lewis
08-21-09 03:07

This is a duplicate of issue 7266, apparently copied verbatim from the original and with an installer tag added. I'm not going to close the issue yet in case the installer tag means something to somebody, but be advised the installer tag references an out of date fix - don't use it. See the original issue 7266 for a correct resolution.
 
(0013244 - 298 - 298 - 298 - 298 - 298 - 298)
KenCausey
08-21-09 21:14

As a guess, I suspect the reason is because the original report involves changes to both the image and the VM and the work done on these is done by more or less separate groups. Having two issues allows one to track the status separately for work required in the VM and work required in the image.
 
(0013251 - 266 - 276 - 276 - 276 - 276 - 276)
lewis
08-23-09 01:51

Ken, your guess is probably correct, and installing M7286-SerialPortManagingNamedNodes-Sk.1.cs after the required VM changes are available would be fine. Actually, installing them right now is harmless; they just won't work yet. My "don't use it" statement is wrong.
 
(0013332 - 33 - 33 - 33 - 33 - 33 - 33)
lewis
10-04-09 18:45

Change set added to Squeak trunk.
 

- Issue History
Date Modified Username Field Change
02-15-09 17:43 Keith_Hodges New Issue
02-15-09 17:43 Keith_Hodges Status new => assigned
02-15-09 17:43 Keith_Hodges Assigned To  => Keith_Hodges
02-15-09 17:43 Keith_Hodges Issue generated from 0007266
02-15-09 17:43 Keith_Hodges Relationship added related to 0007266
02-15-09 17:44 Keith_Hodges Status assigned => testing
02-15-09 17:44 Keith_Hodges Fixed in Version  => 3.11
02-15-09 17:46 Keith_Hodges Description Updated
02-15-09 17:46 Keith_Hodges Note Added: 0012971
02-15-09 17:47 Keith_Hodges File Added: M7286-SerialPortManagingNamedNodes-Sk.1.cs.gz
04-25-09 13:18 lewis Issue Monitored: lewis
08-21-09 03:07 lewis Note Added: 0013243
08-21-09 21:14 KenCausey Note Added: 0013244
08-23-09 01:51 lewis Note Added: 0013251
10-03-09 19:33 Keith_Hodges Status testing => assigned
10-03-09 19:33 Keith_Hodges Assigned To Keith_Hodges => andreas
10-04-09 18:45 lewis Assigned To andreas => lewis
10-04-09 18:45 lewis Status assigned => resolved
10-04-09 18:45 lewis Resolution open => fixed
10-04-09 18:45 lewis Note Added: 0013332
04-18-10 22:04 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
74 total queries executed.
44 unique queries executed.
Powered by Mantis Bugtracker