Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007318 [Squeak Packages] Installer minor always 03-17-09 05:31 03-19-09 06:29
Reporter wiz View Status public  
Assigned To Keith_Hodges
Priority normal Resolution no change required  
Status assigned  
Summary 0007318: Installer Monticello seems to find the wrong package when the name differs only by capitalization.
Description Installer Monticello seems to find the wrong package when the name differs only by capitalization.


See report of example on Pharo list:

http://lists.gforge.inria.fr/pipermail/pharo-project/2009-March/006712.html [^]

Additional Information From the report it looks like the installer get clever about finding names by lower casing them before searching.


Hmm. I think this wants to be in an installer category. It is more likely that than a Monticello bug.

Yours in curiosity and service, --Jerome Peace
Attached Files

- Relationships

- Notes
(0013043 - 271 - 295 - 295 - 295 - 295 - 295)
wiz
03-17-09 05:54

Ha, turns out to be a problem with the name of the file changing while being copied from one repository to another.

So I would put this in the MC bug category. The problem actually being that
the repositories have no way to check the integrity of the external name.
 
(0013045 - 83 - 83 - 83 - 83 - 83 - 83)
KenCausey
03-17-09 16:51

Moved to Squeak Packages project, changed category to Installer, assigned to Keith.
 
(0013046 - 218 - 218 - 218 - 218 - 218 - 218)
KenCausey
03-17-09 16:52

Oops, I failed to read the note. Nonetheless Keith is as likely to dig into this as anyone or maybe Matthew. If in fact this turns out to be a MC and not Installer issue, and this needs to be moved back, let me know.
 
(0013047 - 198 - 228 - 228 - 228 - 228 - 228)
Keith_Hodges
03-17-09 19:46
edited on: 03-17-09 19:47

1. The error occurred in the past
2. They are/were not using MC1.5

I have copied many files from one repository to another using MC1.5 without seeing any problem with filenames changing case.

 
(0013048 - 303 - 303 - 303 - 303 - 303 - 303)
KenCausey
03-18-09 00:36

So, can we say the problem is fixed as of a later version of Monticello and that Pharo or at least Damien should consider installing a distributing a newer version? Pharo has their own separate bug tracking system and should not be expected to be looking here, perhaps this issue should be moved there.
 
(0013050 - 760 - 854 - 854 - 854 - 854 - 854)
wiz
03-18-09 10:40

I tried to resolve the report with my first comment. Resolution no action needed.

The problem that does need addressing is that fouling up the external name of a Monticello file in a repository can have unexpected consequences.
Edgar did this during the 3.10 harvesting cycle.

I can write another report to focus on that. I'm just waiting for a "motivating incident".

The action needed here is to resolve this issue or maybe close it.
Tell the Pharo folks if necessary. I don't think it is their mail list seem to have resolved this issue for them.

I would be good to add 'Installer' to the bug reporting categories.

Of course, if Keith is as good as he thinks he is we will never need it. :)

Yours in curiosity and service, --Jerome Peace
 
(0013051 - 409 - 421 - 421 - 421 - 421 - 421)
Keith_Hodges
03-18-09 11:16
edited on: 03-18-09 11:17

I fear I have given a wrong impression. It is precisely because I know I am not as good as you think I think I am, that I value the whole community working together. If I throw something together over a weekend I know it needs a team contribution to use it and refine it. The pharo boys on the other hand tell us they are good enough to go it alone, and my lowly contributions are below their participation.

 
(0013053 - 771 - 873 - 873 - 873 - 873 - 873)
wiz
03-19-09 06:29

Hi Keith,
[OT] reply:

If you throw something together over a weekend then you owe it to yourself and others not to release it until you have slept on it and tested it once or twice.
DAMHIKT.

Programming is like playing pinball if you do it right you get extra chances to play.

No one will have the time to dive in, understand your code, and repair its bugs.

Perfection is not required. Humility in the form of precaution and testing is.
It should not be impossible to find bugs just damn hard. :-)

I appreciate that you work hard and on stuff that Truly Matters. I also fear the consequences of haste. I sometimes sense you push TOO hard and it scares me.

Other than that I value your qualities of energy, persistence and stubbornness.

Cheers -Jer
 

- Issue History
Date Modified Username Field Change
03-17-09 05:31 wiz New Issue
03-17-09 05:31 wiz Status new => assigned
03-17-09 05:31 wiz Assigned To  => KenCausey
03-17-09 05:54 wiz Note Added: 0013043
03-17-09 05:54 wiz Assigned To KenCausey =>
03-17-09 05:54 wiz Resolution open => no change required
03-17-09 05:54 wiz Category Any => Monticello
03-17-09 16:50 KenCausey Project Squeak => Squeak Packages
03-17-09 16:51 KenCausey Note Added: 0013045
03-17-09 16:51 KenCausey Assigned To  => Keith_Hodges
03-17-09 16:51 KenCausey Category Monticello => Installer
03-17-09 16:52 KenCausey Note Added: 0013046
03-17-09 19:46 Keith_Hodges Note Added: 0013047
03-17-09 19:46 Keith_Hodges Note Edited: 0013047
03-17-09 19:47 Keith_Hodges Note Edited: 0013047
03-18-09 00:36 KenCausey Note Added: 0013048
03-18-09 10:40 wiz Note Added: 0013050
03-18-09 11:16 Keith_Hodges Note Added: 0013051
03-18-09 11:17 Keith_Hodges Note Edited: 0013051
03-19-09 06:29 wiz Note Added: 0013053


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
78 total queries executed.
47 unique queries executed.
Powered by Mantis Bugtracker