Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007323 [Squeak] Kernel minor always 03-28-09 01:01 01-05-13 21:24
Reporter wiz View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0007323: A mother for bugs and problems with Fractions.
Description There are a number of known problems with fractions.
I.E. Numbers whose class = Fraction.
And this has caused pain for developers and those that would use numbers to their fullest.

This is a parent issue to connect reports on those problems.
Additional Information Warpbit can choke if given fractional coordinates.

Things like n/m that you think will produce floats give you fractions instead.

And fractions themselves may turn into integers at any time.

If you do want to use fractions some of the most useful messages are private.
e.g. numerator and denominator.

If you use them anyway you get offbase answers.

All of these have (or will have) their own report.

Here we tie things together and point to hard to reach closed issues.

Attached Files

- Relationships

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

related to 0003373closed  Float asFraction does not handle gradual underflow 
parent of 0006805closed KenCausey Time now seconds returns a fraction. 
parent of 0000478closed ned warpbit bug invoked by simple etoy program 
parent of 0007324closed  Fractions do not give useful access to denominator and numerator 

- Notes
(0014286 - 140 - 146 - 146 - 146 - 146 - 146)
nicolas cellier
01-05-13 21:24

Since all issues are close, bye bye mother...
By the way, Mantis has quite decent filter viewing, so what's the point of all these mothers?
 

- Issue History
Date Modified Username Field Change
03-28-09 01:01 wiz New Issue
03-28-09 01:02 wiz Relationship added parent of 0006805
03-28-09 01:05 wiz Relationship added related to 0003373
03-28-09 01:06 wiz Relationship added parent of 0000478
03-28-09 01:29 wiz Relationship added parent of 0007324
01-05-13 21:24 nicolas cellier Note Added: 0014286
01-05-13 21:24 nicolas cellier Status new => closed
01-05-13 21:24 nicolas cellier Resolution open => fixed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
53 total queries executed.
39 unique queries executed.
Powered by Mantis Bugtracker