Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007331 [Squeak] VM block always 04-08-09 22:12 04-18-10 21:51
Reporter sascha_silbe View Status public  
Assigned To lewis
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0007331: FTBFS on Fedora Rawhide due to dprintf name collision
Description Name collision between dprintf macro from squeak and dprintf function from glibc:

gcc -g -O2 -DLSB_FIRST=1 -DHAVE_CONFIG_H -DSQUEAK_BUILTIN_PLUGIN -I/home/sugar/sugar-jhbuild/source/squeak/bld -I/home/sugar/sugar-jhbuild/source/squeak/platforms/unix/vm -I/home/sugar/sugar-jhbuild/source/squeak/platforms/Cross/vm -I/home/sugar/sugar-jhbuild/source/squeak/platforms/unix/src/vm -I/home/sugar/sugar-jhbuild/source/squeak/platforms/Cross/vm -I/home/sugar/sugar-jhbuild/source/squeak/platforms/unix/src/vm -I/home/sugar/sugar-jhbuild/source/squeak/platforms/unix/vm -I/home/sugar/sugar-jhbuild/source/squeak/platforms/Cross/plugins/FilePlugin
-I/home/sugar/sugar-jhbuild/source/squeak/platforms/unix/plugins/B3DAcceleratorPlugin -I/home/sugar/sugar-jhbuild/source/squeak/bld -I/home/sugar/sugar-jhbuild/source/squeak/platforms/unix/vm -I/home/sugar/sugar-jhbuild/source/squeak/platforms/Cross/vm -I/home/sugar/sugar-jhbuild/source/squeak/platforms/unix/src/vm -DSUGAR -D_FORTIFY_SOURCE=0 -c -o debug.o /home/sugar/sugar-jhbuild/source/squeak/platforms/unix/vm/debug.c
In file included from /home/sugar/sugar-jhbuild/source/squeak/platforms/unix/vm/debug.c:3:
/usr/include/stdio.h:399:66: error: macro "dprintf" passed 3 arguments, but takes just 1
/home/sugar/sugar-jhbuild/source/squeak/platforms/unix/vm/debug.c: In function ‘__sq_assert':
/home/sugar/sugar-jhbuild/source/squeak/platforms/unix/vm/debug.c:21: warning: incompatible implicit declaration of built-in function ‘abort'
make[2]: *** [debug.o] Error 1
make[1]: *** [vm/vm.a] Error 2
make[1]: Leaving directory `/home/sugar/sugar-jhbuild/source/squeak/bld'
make: *** [default] Error 2
Additional Information Filed downstream at Sugarlabs as http://dev.sugarlabs.org/ticket/708 [^]
Attached Files

- Relationships

- Notes
(0013078 - 50 - 50 - 50 - 50 - 50 - 50)
KenCausey
04-09-09 18:07

Recategorized as a VM issue and assigned to David.
 
(0013228 - 390 - 480 - 480 - 480 - 480 - 480)
bert
08-13-09 21:23

Proposed fix:

Rename the Balloon3D DPRINTF to DPRINTF3D and our regular dprintf to DPRINTF:

svn update ...
cd platforms
grep -rl DPRINTF . \
| egrep '(B3D|X11)' \
| grep -v '/\.svn/' \
| tr '\n' '\000' \
| xargs -0 sed -i '' s/DPRINTF/DPRINTF3D/g
grep -rl dprintf . \
| grep -v '/\.svn/' \
| tr '\n' '\000' \
| xargs -0 sed -i '' s/dprintf/DPRINTF/g
svn diff | less
 
(0013648 - 64 - 70 - 70 - 70 - 70 - 70)
laza
04-08-10 11:19

I guess this has been resolved by now.
Can we close this issue?
 
(0013651 - 131 - 131 - 253 - 253 - 253 - 253)
laza
04-08-10 11:38

Since http://bugs.sugarlabs.org/ticket/708 [^] says it is fixed I would assume it is in the vm SVN repo and so is also fixed for Squeak
 
(0013659 - 131 - 131 - 131 - 131 - 131 - 131)
sascha_silbe
04-08-10 12:36

It's fixed in the olpc branch, yes. No idea whether the fix has made it into any other branch but it works at least for us. Thanks!
 

- Issue History
Date Modified Username Field Change
04-08-09 22:12 sascha_silbe New Issue
04-08-09 22:13 sascha_silbe Issue Monitored: sascha_silbe
04-09-09 18:07 KenCausey Note Added: 0013078
04-09-09 18:07 KenCausey Assigned To  => lewis
04-09-09 18:07 KenCausey Status new => assigned
04-09-09 18:07 KenCausey Category System => VM
08-10-09 06:28 tomeu Issue Monitored: tomeu
08-13-09 21:23 bert Note Added: 0013228
04-08-10 11:19 laza Note Added: 0013648
04-08-10 11:19 laza Status assigned => feedback
04-08-10 11:38 laza Status feedback => resolved
04-08-10 11:38 laza Resolution open => fixed
04-08-10 11:38 laza Note Added: 0013651
04-08-10 12:36 sascha_silbe Note Added: 0013659
04-09-10 02:09 lewis Issue Monitored: lewis
04-18-10 21:51 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
66 total queries executed.
44 unique queries executed.
Powered by Mantis Bugtracker