Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007412 [Squeak] Tools minor always 11-13-09 06:03 01-02-13 20:40
Reporter sig View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version trunk
Summary 0007412: Changeset sorter displays a class category against each method instead of method's category
Description A simple change sorter , when you picking some class,
lists all methods that have changed.
And prints a class category name instead the method category name at each list entry.
For example, i changed the methods in Set class, it lists:

add: {Collections-Unordered}
collect: {Collections-Unordered}
do: {Collections-Unordered}
findElementOrNil: {Collections-Unordered}
fixCollisionsFrom: {Collections-Unordered}
like: {Collections-Unordered}
like:ifAbsent: {Collections-Unordered}
like:ifNone: {Collections-Unordered}
noCheckAdd: {Collections-Unordered}
noCheckNoGrowFillFrom: {Collections-Unordered}
scanFor: {Collections-Unordered}
Additional Information
Attached Files

- Relationships

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

related to 0007342pending  Change Sorters in 3.10.2 no longer report about class definitions or class comments. 
related to 0005831closed  [RFE] Changesorters need to report packages of methods and Classes 
related to 0007463pending  In sq 8955 ChangeSorter has a multiple number of ailments 

- Notes
(0013433 - 1151 - 1241 - 1241 - 1241 - 1241 - 1241)
wiz
12-14-09 23:08

Hi Sig,

This was my addition to 3.10.2
The category shown is what I had intended.

The reason for adding the annotation was to make the user aware of the package that the method would belong to. So it shows the class category for most methods and the *method-category for methods which belong to packages other than their classes. The point of this was to make the coder aware if he was cutting across package boundaries.

The context of the problem was to make changesorters more compatible with Monticello.

The annotation implementation is flawed. There was a pattern I should have followed that I wasn't aware of at the time. Pharo reverted back to the changesorter w/o the package/category annotation feature.

Its been my intention to do a rewrite iteration. I haven't because the first thing I need are some file in file out tests for changesorter so I can avoid the problems I caused in my original implementation. That requires study. And time which I haven't allocated to the task.

The number of forks have left me without a clear reason to donate time to squeak development.

Yours in curiosity and service, --Jerome Peace
 
(0013570 - 228 - 264 - 264 - 264 - 264 - 264)
wiz
03-18-10 22:48

Q: Would it help if the package category were more clearly annotated

instead of {Class category} or {*method-category}

have {pkg:Class catefory} or {pkg:*method-category} ?

Yours in curiosity and service, --Jerome Peace
 
(0014274 - 86 - 89 - 89 - 89 - 89 - 89)
nicolas cellier
01-02-13 20:37

This bug must have been integrated for a long time and doesn't show up in 4.4 => close
 

- Issue History
Date Modified Username Field Change
11-13-09 06:03 sig New Issue
12-14-09 23:08 wiz Note Added: 0013433
12-14-09 23:09 wiz Relationship added related to 0007342
12-14-09 23:11 wiz Relationship added related to 0005831
02-02-10 03:15 wiz Relationship added related to 0007463
03-18-10 22:48 wiz Note Added: 0013570
01-02-13 20:37 nicolas cellier Note Added: 0014274
01-02-13 20:38 nicolas cellier Issue Monitored: nicolas cellier
01-02-13 20:39 nicolas cellier Issue End Monitor: nicolas cellier
01-02-13 20:40 nicolas cellier Status new => closed
01-02-13 20:40 nicolas cellier Resolution open => fixed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
61 total queries executed.
41 unique queries executed.
Powered by Mantis Bugtracker