Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007426 [Squeak] VM crash always 12-09-09 05:34 11-23-10 15:19
Reporter sig View Status public  
Assigned To lewis
Priority normal Resolution duplicate  
Status resolved   Product Version trunk
Summary 0007426: 'Run object as method' feature leads to crash if object is smallinteger
Description
VM crashing if you installing a SmallInteger into method dictionary as a method.

See the test in attachment.
Additional Information
Attached Files  TestObjectsAsMethods-testCrashWithSmallInt.st [^] (357 bytes) 12-09-09 05:34

- Relationships
duplicate of 0007157resolved lewis Using ObjectAsMethod (#primitiveInvokeObjectAsMethod) crashes VM 

- Notes
(0013431 - 279 - 297 - 297 - 297 - 297 - 297)
lewis
12-09-09 18:12
edited on: 12-09-09 18:16

The test crashes a 32-bit unix VM on Linux. Interestingly, it does *not* crash a 64-bit VM on the same platform (the self answer10 part of the test passes with the expected exception, although the test fails on the #basicRemoveSelector: with a DNU on SmallInteger>>flushCache).

 
(0013661 - 28 - 28 - 28 - 28 - 28 - 28)
laza
04-08-10 13:12

Is this a duplicate of 7157?
 

- Issue History
Date Modified Username Field Change
12-09-09 05:34 sig New Issue
12-09-09 05:34 sig Status new => assigned
12-09-09 05:34 sig Assigned To  => lewis
12-09-09 05:34 sig File Added: TestObjectsAsMethods-testCrashWithSmallInt.st
12-09-09 18:12 lewis Note Added: 0013431
12-09-09 18:12 lewis Status assigned => acknowledged
12-09-09 18:16 lewis Note Edited: 0013431
04-08-10 13:12 laza Relationship added related to 0007157
04-08-10 13:12 laza Note Added: 0013661
11-23-10 15:19 leves Relationship replaced duplicate of 0007157
11-23-10 15:19 leves Duplicate ID 0 => 7157
11-23-10 15:19 leves Status acknowledged => resolved
11-23-10 15:19 leves Resolution open => duplicate


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
56 total queries executed.
37 unique queries executed.
Powered by Mantis Bugtracker