Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007436 [Squeak] OS-Linux minor always 01-09-10 03:16 04-18-10 21:55
Reporter wiz View Status public  
Assigned To laza
Priority normal Resolution fixed  
Status closed   Product Version trunk
Summary 0007436: Close box no longer allows exit from squeak.
Description For this one.
In a fresh Squeak3.11-8720-alpha.image
Go to the object tab affixed to the top of the screen.
Use the mouse buttons to call up the halos.
Try to resize the tab with the yellow halo button.
You will run into bug 0006486 an infinite recursion.

Now try to stop the image.

The old behavior was that clicking the [x] close box would close without saving.
That has been modified to avoid the obvious loss of work.

The problem is that it is replaced with a null operation.
This is not useful.

The proper behavior is it should suspend all squeak activity except for a dialog allowing the user the choice of quitting without saving or canceling the close request.

On a Ubuntu system I had to go into the terminal to explicitly kill the process. That was the only way out of the situation.

Yours in curiosity and service, --Jerome Peace
Additional Information
Attached Files

- Relationships
related to 0007477closed lewis Close box no longer allows exit from squeak. 

- Notes
(0013547 - 518 - 599 - 599 - 599 - 599 - 599)
laza
03-11-10 11:21

Now there are at least two things in here.

> The problem is that it is replaced with a null operation.
> This is not useful.

With trunk 9683 HostWindowEvents will be handled and so closing a squeak window under linux will present an in image dialog

> The proper behavior is it should suspend all squeak activity
> except for a dialog allowing the user the choice of quitting
> without saving or canceling the close request.

This is a feature request for the linux VM. I created a separate issue for this
 
(0013556 - 76 - 88 - 88 - 88 - 88 - 88)
wiz
03-12-10 20:42

Tried it in sq 9686. It works. It's wonderful. Thanks laza.

Cheers, --Jer
 
(0013567 - 53 - 53 - 53 - 53 - 53 - 53)
laza
03-17-10 18:00

BTW, all the credit for this belongs to Bert and John
 

- Issue History
Date Modified Username Field Change
01-09-10 03:16 wiz New Issue
01-09-10 03:16 wiz Status new => assigned
01-09-10 03:16 wiz Assigned To  => KenCausey
01-11-10 22:31 KenCausey Assigned To KenCausey =>
01-11-10 22:31 KenCausey Status assigned => new
01-11-10 22:31 KenCausey Category Any => Morphic
01-11-10 22:31 KenCausey Description Updated
03-09-10 15:23 laza Status new => confirmed
03-09-10 15:23 laza Category Morphic => OS-Linux
03-11-10 11:19 laza Issue cloned 0007477
03-11-10 11:19 laza Relationship added related to 0007477
03-11-10 11:21 laza Status confirmed => resolved
03-11-10 11:21 laza Fixed in Version  => trunk
03-11-10 11:21 laza Resolution open => fixed
03-11-10 11:21 laza Assigned To  => laza
03-11-10 11:21 laza Note Added: 0013547
03-12-10 20:42 wiz Note Added: 0013556
03-17-10 18:00 laza Note Added: 0013567
04-18-10 21:55 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
65 total queries executed.
42 unique queries executed.
Powered by Mantis Bugtracker