Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007481 [Squeak] Janitorial major always 03-19-10 03:40 03-30-10 17:56
Reporter wiz View Status public  
Assigned To
Priority high Resolution duplicate  
Status closed   Product Version trunk
Summary 0007481: In sq 9721 many old unimplemented calls remain unfixed and new unimplemented calls have appeared as well.
Description The old report 0007042 had many fixes in it. They have been languishing.

Other new ones have appeared.

So I am freshing the issue by restating it and uploading checked and revised versions of those old fixes.

Gathering some of the new fixes.

Then hopefully providing a test to catch the problem closer to the source.

Additional Information First a change set of all still needed fixes from 0007042.
Attached Files  Sq9721UnImpCallFixes-wiz.1.cs [^] (7,704 bytes) 03-19-10 03:40
 WarpBlt-warpBitsSmoothingsourceMap.st [^] (2,495 bytes) 03-19-10 04:00
 SequenceableCollection-assertSlopesWithfromto.st [^] (1,065 bytes) 03-19-10 04:01
 PseudoClass-theMetaClass.st [^] (193 bytes) 03-19-10 04:02
 PositionableStream-errorCantGoBack.st [^] (218 bytes) 03-19-10 04:03
 DisplayScreen class-depthwidthheightfullscreen.st [^] (444 bytes) 03-19-10 04:04
 ChangeSet-mailOut.st [^] (919 bytes) 03-19-10 04:04
 ADPCMCodec-privateEncodeStereo.st [^] (324 bytes) 03-19-10 04:04
 Bitmap-decompressfromByteArrayat.st [^] (2,318 bytes) 03-19-10 04:05
 EToyVocabulary-applyMasterOrdering.st [^] (351 bytes) 03-19-10 04:14

- Relationships

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

duplicate of 0007483closed andreas [tests] [fixes] Tests and fixes for unimplemented calls updated for sq 9787 
parent of 0007042closed wiz [fixes][tests] Whitling down unimplemented calls in sq7159 
child of 0007480feedback  Issues that should be fixed in 4.1 

- Notes
(0013574 - 587 - 711 - 711 - 711 - 711 - 711)
wiz
03-19-10 04:16

WarpBlt-warpBitsSmoothingsourceMap.st
 SequenceableCollection-assertSlopesWithfromto.st
 PseudoClass-theMetaClass.st
 PositionableStream-errorCantGoBack.st
 EToyVocabulary-applyMasterOrdering.st
 DisplayScreen class-depthwidthheightfullscreen.st
 ChangeSet-mailOut.st
 ADPCMCodec-privateEncodeStereo.st
 Bitmap-decompressfromByteArrayat.st

Are the individual method changes contained in the above changeset.

If you load the changeset you can ignore them. However if you read the earlier report you will see why I have uploaded the pieces as well as the set.

--Jer
 
(0013604 - 799 - 883 - 883 - 1118 - 1118 - 1118)
nicolas cellier
03-30-10 17:55

1) this report is superseded by 0007483
Multiplying the reports for the same issue maybe helpful.
But If we don't close the obsolete ones, it just add confusion!
Consequently, I close the old ones (0007042 and this one) as duplicated.

2) IMO, not all changes are acceptable.
I think I integrated what could be integrated already.
What I do not agree with are these:

a) Do not comment #success: this message is for generating the plugin.
b) Do not replace primitiveFail (for generating plugin) with primitiveFailed (raise an Error in the image)
c) Do not define #applyMasterOrdering, otherwise it will result in nasty overrides.
(self respondsTo: #applyMasterOrdering) is protecting the unimplemented call.

3) I agree that incriminated code is not nice, but we must find better solutions
 
(0013605 - 19 - 19 - 19 - 145 - 145 - 145)
nicolas cellier
03-30-10 17:56

Superseded by 0007483
 

- Issue History
Date Modified Username Field Change
03-19-10 03:40 wiz New Issue
03-19-10 03:40 wiz File Added: Sq9721UnImpCallFixes-wiz.1.cs
03-19-10 03:48 wiz Relationship added parent of 0007042
03-19-10 03:49 wiz Summary In sq 9721 many old unimplemented calls remain unfix and new unimplemented calls have appeared as well. => In sq 9721 many old unimplemented calls remain unfixed and new unimplemented calls have appeared as well.
03-19-10 03:55 wiz Relationship added child of 0007480
03-19-10 04:00 wiz File Added: WarpBlt-warpBitsSmoothingsourceMap.st
03-19-10 04:01 wiz File Added: SequenceableCollection-assertSlopesWithfromto.st
03-19-10 04:02 wiz File Added: PseudoClass-theMetaClass.st
03-19-10 04:03 wiz File Added: PositionableStream-errorCantGoBack.st
03-19-10 04:03 wiz File Added: EToyVocabulary.wiz.1.cs
03-19-10 04:04 wiz File Added: DisplayScreen class-depthwidthheightfullscreen.st
03-19-10 04:04 wiz File Added: ChangeSet-mailOut.st
03-19-10 04:04 wiz File Added: ADPCMCodec-privateEncodeStereo.st
03-19-10 04:05 wiz File Added: Bitmap-decompressfromByteArrayat.st
03-19-10 04:14 wiz File Added: EToyVocabulary-applyMasterOrdering.st
03-19-10 04:14 wiz File Deleted: EToyVocabulary.wiz.1.cs
03-19-10 04:16 wiz Note Added: 0013574
03-26-10 00:35 wiz Relationship added duplicate of 0007483
03-30-10 17:55 nicolas cellier Note Added: 0013604
03-30-10 17:56 nicolas cellier Status new => closed
03-30-10 17:56 nicolas cellier Note Added: 0013605
03-30-10 17:56 nicolas cellier Resolution open => duplicate


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
81 total queries executed.
41 unique queries executed.
Powered by Mantis Bugtracker