Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007482 [Squeak] VM major always 03-24-10 08:48 04-18-10 21:51
Reporter laza View Status public  
Assigned To lewis
Priority normal Resolution fixed  
Status closed   Product Version trunk
Summary 0007482: bug in the image segment loading code
Description From the Squeak mailing list: "The issue is that the image format changed for closures and there's been a bug in the image segment loading code that makes the primitive fail in cases where the image format is older, but compatible. I've posted a fix for that in VMMaker ... Obviously, this fix requires new VMs."

http://lists.squeakfoundation.org/pipermail/squeak-dev/2010-March/146932.html [^]
Additional Information This is the reason for the MNU with SqueakMap Package Loader
Attached Files

- Relationships
child of 0007480feedback  Issues that should be fixed in 4.1 

- Notes
(0013579 - 151 - 151 - 151 - 151 - 151 - 151)
lewis
03-25-10 01:34

Andreas provided a fix for this in the VM, and added it to VMMaker on SqueakSource in VMMaker-ar.162. The fix will be included in all future VM builds.
 
(0013585 - 100 - 100 - 100 - 100 - 100 - 100)
leves
03-27-10 21:27

I built a unix vm today with this fix, but it didn't solve the issue. Primitive 99 is still failing.
 
(0013636 - 115 - 115 - 115 - 115 - 115 - 115)
andreas
04-08-10 03:39

Fixed. Both current Mac and Windows VM have fixes; David verified that a Linux VM from latest sources is fixed too.
 

- Issue History
Date Modified Username Field Change
03-24-10 08:48 laza New Issue
03-24-10 08:48 laza Status new => assigned
03-24-10 08:48 laza Assigned To  => lewis
03-24-10 08:49 laza Assigned To lewis =>
03-24-10 08:49 laza Status assigned => confirmed
03-24-10 08:49 laza Relationship added child of 0007480
03-24-10 09:02 laza Description Updated
03-25-10 01:34 lewis Note Added: 0013579
03-25-10 01:34 lewis Status confirmed => acknowledged
03-25-10 11:20 laza Status acknowledged => assigned
03-25-10 11:20 laza Assigned To  => lewis
03-25-10 11:20 laza Status assigned => pending
03-27-10 21:27 leves Note Added: 0013585
04-08-10 03:39 andreas Status pending => resolved
04-08-10 03:39 andreas Resolution open => fixed
04-08-10 03:39 andreas Note Added: 0013636
04-18-10 21:51 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
60 total queries executed.
38 unique queries executed.
Powered by Mantis Bugtracker