Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007484 [Squeak] SqueakMap major sometimes 03-29-10 21:50 04-18-10 21:51
Reporter wiz View Status public  
Assigned To gokr
Priority normal Resolution fixed  
Status closed   Product Version trunk
Summary 0007484: In squeak 9810 squeak map tool can be in an uninitializable state, this breaks some tabs in object tool.
Description For a description of how the dependencies percolate read my note in 0006780.

Basicly the SqueakMap tool is depending on some external state. If that state is consistent all is ok. If it is not then the dependicies will trip things up until the tools tab in the objects tool (and presumable the objects flap) cannot be openned.

Additional Information
This problem is an old one. Part of the cure was to break the dependencies by having the thumbnail independent of the tool. Then the problem is delay until someone actually wants a sqeuak map.

I suspect that the standard icons for tools got removed probably at the same time the ImageMorph default image was cleaned out.

So now the object tool problem is back.

Attached Files

- Relationships
child of 0007480feedback  Issues that should be fixed in 4.1 

- Notes
(0013600 - 108 - 114 - 114 - 211 - 211 - 211)
nicolas cellier
03-29-10 22:44

Jerome, I don't understand. Too much implicit knowledge in your message for me.
Anything related to 0007485 ?
 
(0013633 - 102 - 102 - 102 - 410 - 410 - 410)
andreas
04-08-10 03:30

Fixed. There were several related issues, including 0006780, 0007482 and 0007485. All of these are resolved.
 

- Issue History
Date Modified Username Field Change
03-29-10 21:50 wiz New Issue
03-29-10 21:50 wiz Status new => assigned
03-29-10 21:50 wiz Assigned To  => gokr
03-29-10 21:50 wiz Relationship added child of 0007480
03-29-10 22:44 nicolas cellier Note Added: 0013600
04-08-10 03:30 andreas Status assigned => resolved
04-08-10 03:30 andreas Resolution open => fixed
04-08-10 03:30 andreas Note Added: 0013633
04-18-10 21:51 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
51 total queries executed.
39 unique queries executed.
Powered by Mantis Bugtracker