Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007500 [Squeak] VM block always 04-12-10 05:52 04-18-10 21:51
Reporter wiz View Status public  
Assigned To lewis
Priority urgent Resolution fixed  
Status closed   Product Version
Summary 0007500: Sound is missing from vm Squeak-4.0.3.2196-linux_i386
Description for this one

launch a fresh sq 9938 in the new vm
In a workspace do "Beeper beep"
Note lack of sound.

Compare with launching the same sq image with
Squeak-4.0.2.2181-linux_i386-1
which will play the sound but latches up the cpu to 100%.

On the system I have tested this with pulseaudio (which come standard) is still installed.

Ubuntu 8.04



Additional Information I marked this as block because sound is essential to me.

Yours in curiosity and service, --Jerome Peace
Attached Files

- Relationships
related to 0007504closed wiz In 4.1rc5 sq 9948 sometimes pressing ctrl-d or alt-d closes the image. (Ubuntu/Linux) 
related to 0007503assigned lewis Sound choppy on linux 

- Notes
(0013689 - 234 - 246 - 246 - 246 - 246 - 246)
dmoc
04-13-10 09:50
edited on: 04-13-10 10:03

New PA code sent to Ian (April 13th). When available please test both play and record *without* monitoring audio levels. PA's audio monitoring utility sets a low latency which will mask any latency problems with Squeak's PA plug-in.

 
(0013694 - 113 - 113 - 317 - 317 - 317 - 317)
laza
04-13-10 12:12

This seems to be fixed according to http://lists.squeakfoundation.org/pipermail/squeak-dev/2010-April/148640.html [^]
 
(0013701 - 456 - 466 - 466 - 466 - 466 - 466)
dmoc
04-13-10 12:49

@laza, thanks for the link. It was that post which prompted me to check sound today using 4.0.3.2200. If you try "Beeper beep" it may appear to play ok because it is a short sample but if you do it several times in quick succession then it doesn't sound too healthy. Using the PianoKeyboard morph to play a steady note reveals playback to be choppy. I replaced the PA plugin with a version done for Scratch in Feb and now playback and record work properly.
 
(0013706 - 113 - 119 - 119 - 119 - 119 - 119)
laza
04-13-10 18:10

This issue is about no sound at all on linux, which has been resolved.
I opened a new issue for the new PA code.
 
(0013707 - 832 - 922 - 1090 - 1090 - 1090 - 1090)
wiz
04-14-10 00:23

From the post laza refered to:

http://piumarta.com/tmp/Squeak-4.0.3.2196-linux_i386.tar.gz [^]

Ok. Sounds back. pulseaudio does NOT latch up. Good.

There may still be some problem with terminating the sound. I am finding after I have played with squeak, using the firefox browser to play youtube video's can lead to the browser slowing down to a painful crawl. Things don't clear up until the browser is closed.

So I am suspecting that there is an interaction between a resource squeak is not properly releasing and the browsers rendering of the video's.

How would one test for this at squeaks end of things?

If I can figure how to support my suspicions I'll open a new report. It's a little off topic for this one. This one is resolved by the new vm package above.


Yours in curiosity and service, --Jerome Peace
 
(0013714 - 955 - 1063 - 1063 - 1063 - 1063 - 1063)
wiz
04-17-10 03:23

The title here is wrong.
There is sound in 2196.

The lack of sound was in an early tentative version of 2022. That was fixed before it was released with Squeak RC5.

The 2196 vm apparently solved the latch up problem by missing the pulseaudio plugin. That allowed my Ubuntu system to have sound thru some other mechanism probalby the alsa? plugin.

Unfortunately leaving the module out has an unfortunate interaction with the #stopSoundWhenDone preference. See the related report.

So current state of affairs:

linux vm for RC5 = vm2022 (with pulseaudio sound plugin)
Sound works but will latch up the cpu.
The stopSoundWhenDone preference is preset in Squeak 4.1.1 RC5.
This works around the problem of cpu latchup by shutting off the sound. Then the cpu usage goes back to normal.

It would be nice to have an even better solution but the current one is sufficient for goverment work.

Yours in curiosity and service, --Jerome Peace
 
(0013715 - 1672 - 1933 - 1933 - 1933 - 1933 - 1933)
wiz
04-17-10 04:00

Okay ran things from the console and got the following console log.

This confirms the problem was with the sound module.

And completes this investigation

Problem is fixed with RC5 release and RC5 vm2022.

====


hubuntu@hubuntu-desktop:~$ '/home/hubuntu/Documents/squeakish/trunk/Squeak-4.0.3.2196-linux_i386b/Squeak-4.0.3.2196-linux_i386/bin/squeak' '/home/hubuntu/Documents/squeakish/trunk/4.1rc5/Squeak4.1.1.image'
SQUEAK_ENCODING='UTF-8'
SQUEAK_PATHENC='UTF-8'
SQUEAK_PLUGINS='/home/hubuntu/Documents/squeakish/trunk/Squeak-4.0.3.2196-linux_i386b/Squeak-4.0.3.2196-linux_i386/lib/squeak/4.0.3-2196'
+ exec /home/hubuntu/Documents/squeakish/trunk/Squeak-4.0.3.2196-linux_i386b/Squeak-4.0.3.2196-linux_i386/lib/squeak/4.0.3-2196/squeakvm /home/hubuntu/Documents/squeakish/trunk/4.1rc5/Squeak4.1.1.image
setlocale() failed (check values of LC_CTYPE, LANG and LC_ALL)
openPulseAudio() play, rate: 22050, chans: 2
setlocale() failed (check values of LC_CTYPE, LANG and LC_ALL)
sound_Start() frameCount >> 1: 1322
closePulseAudio((): play

<got this far with first control p over Beeper Beep. Tried ctrl-p a few more times over Beeper. Then selected Beeper beep again. Next ctrl-p caused the segmentation fault.>

openPulseAudio() play, rate: 22050, chans: 2
sound_Start() frameCount >> 1: 1322

Segmentation fault

1988865796 SoundPlayer class>playLoop
1988865616 Semaphore>critical:
1988865524 BlockClosure>ensure:
1988865408 Semaphore>critical:
1988832920 SoundPlayer class>playLoop
1988832828 SoundPlayer class>startPlayerProcessBufferSize:rate:stereo:sound:
1988833196 BlockClosure>newProcess
Aborted
hubuntu@hubuntu-desktop:~$
 

- Issue History
Date Modified Username Field Change
04-12-10 05:52 wiz New Issue
04-12-10 05:52 wiz Status new => assigned
04-12-10 05:52 wiz Assigned To  => lewis
04-13-10 09:50 dmoc Note Added: 0013689
04-13-10 10:03 dmoc Note Edited: 0013689
04-13-10 12:12 laza Status assigned => resolved
04-13-10 12:12 laza Fixed in Version  => trunk
04-13-10 12:12 laza Resolution open => fixed
04-13-10 12:12 laza Note Added: 0013694
04-13-10 12:49 dmoc Note Added: 0013701
04-13-10 17:30 laza Note Added: 0013704
04-13-10 18:03 laza Note Deleted: 0013704
04-13-10 18:06 laza Issue cloned 0007503
04-13-10 18:06 laza Relationship added related to 0007503
04-13-10 18:10 laza Note Added: 0013706
04-14-10 00:23 wiz Note Added: 0013707
04-17-10 03:13 wiz Relationship added related to 0007504
04-17-10 03:23 wiz Note Added: 0013714
04-17-10 04:00 wiz Note Added: 0013715
04-18-10 21:51 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
85 total queries executed.
51 unique queries executed.
Powered by Mantis Bugtracker