Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007503 [Squeak] VM major always 04-13-10 18:06 04-14-10 01:48
Reporter dmoc View Status public  
Assigned To lewis
Priority none Resolution open  
Status assigned   Product Version trunk
Summary 0007503: Sound choppy on linux
Description New PA code sent to Ian (April 13th). When available please test both play and record *without* monitoring audio levels. PA's audio monitoring utility sets a low latency which will mask any latency problems with Squeak's PA plug-in.
Additional Information
Attached Files

- Relationships
related to 0007500closed lewis Sound is missing from vm Squeak-4.0.3.2196-linux_i386 

- Notes
(0013705 - 30 - 30 - 30 - 30 - 30 - 30)
laza
04-13-10 18:07

I've split that issue into two
 
(0013710 - 556 - 631 - 631 - 631 - 631 - 631)
wiz
04-14-10 01:48

From dmoc:

 It was that post which prompted me to check sound today using 4.0.3.2200.

If you try "Beeper beep" it may appear to play ok because it is a short sample.

If you do it several times in quick succession then it doesn't sound too healthy.

Using the PianoKeyboard morph to play a steady note reveals playback to be choppy. I replaced the PA plugin with a version done for Scratch in Feb and now playback and record work properly.

I've reproduced the relevant portion of dmoc's note so the issue has a recipe for the problem. --Jer
 

- Issue History
Date Modified Username Field Change
04-13-10 18:06 laza New Issue
04-13-10 18:06 laza Status new => assigned
04-13-10 18:06 laza Assigned To  => lewis
04-13-10 18:06 laza Issue generated from 0007500
04-13-10 18:06 laza Relationship added related to 0007500
04-13-10 18:07 laza Note Added: 0013705
04-13-10 18:07 laza Reporter laza => dmoc
04-14-10 01:48 wiz Note Added: 0013710


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
48 total queries executed.
36 unique queries executed.
Powered by Mantis Bugtracker