Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007504 [Squeak] Sound block sometimes 04-15-10 20:09 04-18-10 21:51
Reporter wiz View Status public  
Assigned To wiz
Priority normal Resolution no change required  
Status closed   Product Version trunk
Summary 0007504: In 4.1rc5 sq 9948 sometimes pressing ctrl-d or alt-d closes the image. (Ubuntu/Linux)
Description This is a intermittent though redily producable bug.

Context: In the welcome window I typed Beeper beep.
Selected it. And typed Alt-d to play it. Then I typed Ctrl-d to play it.

Then I pressed the mouse button and got beam cursor. The next press of ctrl-d closed the image. presumably without saving it.

The vm was Squeak-4.0.3.2196-linux_i386/bin/squeak (the last one for which sound does not latch up the cpu).

Additional Information This is a very strange and troublesome bug. Without warning all work could be lost at the stroke of a commonly use key. Thus the block designation.

At this point I have no clue as to what is causing it.

Sometimes ctrl-d causes the doit to happen sometimes it closes the image.

Sometimes alt-d causes the doit to happen sometimes it closes the image.

What is going on.

How can we test for it?
How can we test for it being solved?

Yours in curiosity and service,
Attached Files

- Relationships
related to 0007500closed lewis Sound is missing from vm Squeak-4.0.3.2196-linux_i386 

- Notes
(0013712 - 443 - 519 - 519 - 519 - 519 - 519)
wiz
04-15-10 20:42

More data points.

So far I've only readily gotten the closing with the combination of
sq RC5 and the vm2196.

I have tried recreating the problem with RC5-vmRc5(vm2202).
And with RC4 and vm2196. Neither have crashed on me.

RC5 seems to have the sound preference set to stopWhenDone.
The pulseaudio latchup happens(vm2202) but stops on its own after awhile.
There is no latchup in vm2196, which is why I was using it.

YIC&S --Jer
 
(0013713 - 807 - 939 - 939 - 939 - 939 - 939)
wiz
04-16-10 03:19

Ah. I now have a suspect.

RC5 at my request has Preference stopSoundWhenDone set.

The other images I tried didn't.

vm2196 solved the cpu latchup problem because it was missing the pulse audio module. Some other module (alsa?) was playing the sound.

So using RC4 and the vm2196 I used the preference browser to set the stopSoundWhenDone preference.
ran Beeper beep with a doit.
waited until the cpu usage (as shown by the monitor) went down.
pressed ctrl-d

Note: squeak closed.

Oddly, Ken Causey gave me the clue by categorizing this report as sound.

Once I know how I will try to confirm this with a system trace from the console.
Once I know what the console is.

Ah, the pleasures of navigating through a vast sea of ignorance.

Yours in curiosity and service, --Jerome Peace
 
(0013717 - 236 - 248 - 248 - 248 - 248 - 248)
wiz
04-18-10 03:54

Problem is related due to an interaction of a preference and a (missing?) sound module in an interm linux vm(2196).
The sound module is present in the current release 4.1 final. vm2022.
No other action needs to be taken at this time.
 

- Issue History
Date Modified Username Field Change
04-15-10 20:09 wiz New Issue
04-15-10 20:09 wiz Status new => assigned
04-15-10 20:09 wiz Assigned To  => KenCausey
04-15-10 20:42 wiz Note Added: 0013712
04-15-10 21:08 KenCausey Assigned To KenCausey =>
04-15-10 21:08 KenCausey Status assigned => new
04-15-10 21:08 KenCausey Category Any => Sound
04-16-10 03:19 wiz Note Added: 0013713
04-17-10 03:13 wiz Relationship added related to 0007500
04-17-10 12:21 lewis Issue Monitored: lewis
04-18-10 03:54 wiz Status new => resolved
04-18-10 03:54 wiz Fixed in Version  => trunk
04-18-10 03:54 wiz Resolution open => no change required
04-18-10 03:54 wiz Assigned To  => wiz
04-18-10 03:54 wiz Note Added: 0013717
04-18-10 21:51 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
59 total queries executed.
40 unique queries executed.
Powered by Mantis Bugtracker