Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007589 [Squeak] Graphics minor always 12-21-10 23:47 10-22-13 05:25
Reporter matthewf View Status public  
Assigned To tim
Priority normal Resolution no change required  
Status closed   Product Version
Summary 0007589: text composer and character scanner disagree on the width of a paragraph of antialiased strikefonts
Description the character scanner disagrees with the text composer on how wide paragraphs made of antialiased strikefonts are. This was causing non-word-wrapped paragraphs in Tweak to have their last character chopped off, due to MultiCharacterScanner >> displayLine:offset:leftInRun: stopping because of #crossedX rather than #endOfRun. However I changed CTextParagraph >> adjustRightXBy: to behave like NewParagraph >> adjustRightX, and the visual effect of this bug went away. Nevertheless, it seems like it still should be fixed

Test case is in the inbox: Tests-mtf.105
Additional Information
Attached Files

- Relationships
related to 0001650closed tim [BUG] CharacterScanner primitive is broken; char scanning generally in a mess 

- Notes
(0014469 - 77 - 77 - 77 - 77 - 77 - 77)
tim
10-22-13 05:25

Scanners have been fixed up a lot and CTextParagraph has gone missing anyway.
 

- Issue History
Date Modified Username Field Change
12-21-10 23:47 matthewf New Issue
12-21-10 23:47 matthewf Status new => assigned
12-21-10 23:47 matthewf Assigned To  => andreas
12-23-10 15:55 matthewf Description Updated
12-23-10 16:22 lewis Issue Monitored: lewis
09-30-13 22:28 tim Assigned To andreas => tim
09-30-13 23:22 tim Relationship added related to 0001650
10-22-13 05:25 tim Status assigned => resolved
10-22-13 05:25 tim Resolution open => no change required
10-22-13 05:25 tim Note Added: 0014469
10-22-13 05:25 tim Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
49 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker