Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007614 [Squeak] VM crash always 03-10-11 11:33 03-11-11 00:57
Reporter sergio View Status public  
Assigned To lewis
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0007614: Fresh 4.2 crashes on Debian x64 on change interface global settings from menues
Description Fresh downloaded and unpacked 4.2 crashed when I click "Extras/Window Colours/Uniform Windows", or when I choose "Apps/Preference Browser" and try to choose there "Themes/smallLand", or when I in Prefernce Browser set "general/bigDisplay" to enable or set tinyDisplay to enable.
Additional Information Debian GNU/Linux amd64 lenny/squeeze release, GNOME DE.
No other problems noticed yet. :)
Attached Files  oncrash_console_output.tar.bz2 [^] (1,552 bytes) 03-10-11 11:56

- Relationships
duplicate of 0007358acknowledged lewis UUID>>initialize may crash VM for some images 

- Notes
(0014059 - 2130 - 2550 - 2550 - 2550 - 2550 - 2550)
sergio
03-10-11 11:44

Sorry, there is console output on crash, so it is here:

sergio@bagira:~/.squeak/My Squeak/Squeak 4.2 All-in-One.app$ bash
sergio@bagira:~/.squeak/My Squeak/Squeak 4.2 All-in-One.app$ LC_ALL=C
sergio@bagira:~/.squeak/My Squeak/Squeak 4.2 All-in-One.app$ ./squeak.sh
Running 32-bit Squeak on a 64-bit System. Hope the 32-bit runtime libraries are installed ...

Segmentation fault

-1207817924 UUID>initialize
-1207818016 Behavior>new:
-1207818220 UUID class>new
-1207818312 TheWorldMainDockingBar class>setTimeStamp
-1207818516 TheWorldMainDockingBar class>updateInstances
-1208020960 Preferences class>installWindowColorsVia:
-1208021076 Preferences class>installUniformWindowColors
-1208021168 MenuItemMorph>invokeWithEvent:
-1208021284 BlockClosure>ensure:
-1208021376 Cursor>showWhile:
-1208021600 MenuItemMorph>invokeWithEvent:
-1208021692 MenuItemMorph>mouseUp:
-1208021784 MenuItemMorph>handleMouseUp:
-1208021876 MouseButtonEvent>sentTo:
-1208021968 Morph>handleEvent:
-1208022100 MorphicEventDispatcher>dispatchDefault:with:
-1208022192 MorphicEventDispatcher>dispatchEvent:with:
-1208022284 Morph>processEvent:using:
-1208022376 MorphicEventDispatcher>dispatchDefault:with:
-1208022484 MorphicEventDispatcher>dispatchEvent:with:
-1208022616 Morph>processEvent:using:
-1208022708 Morph>processEvent:
-1208022800 MenuMorph>handleFocusEvent:
-1208022892 HandMorph>sendFocusEvent:to:clear:
-1208022984 PasteUpMorph>becomeActiveDuring:
-1208023164 BlockClosure>on:do:
-1208023256 PasteUpMorph>becomeActiveDuring:
-1208023376 HandMorph>sendFocusEvent:to:clear:
-1208023468 HandMorph>sendEvent:focus:clear:
-1208023560 HandMorph>sendMouseEvent:
-1208023704 HandMorph>handleEvent:
-1208024008 HandMorph>processEvents
-1208024124 WorldState>doOneCycleNowFor:
-1208024216 SequenceableCollection>do:
-1208024316 WorldState>handsDo:
-1208024408 WorldState>doOneCycleNowFor:
-1208024500 WorldState>doOneCycleFor:
-1208024592 PasteUpMorph>doOneCycle
-1218385600 Project class>?
-1218385732 BlockClosure>newProcess
Aborted
sergio@bagira:~/.squeak/My Squeak/Squeak 4.2 All-in-One.app$
 
(0014061 - 43 - 43 - 43 - 151 - 151 - 151)
KenCausey
03-10-11 17:26

This appears to be the same issue as 0007358.
 
(0014062 - 877 - 979 - 979 - 1087 - 1087 - 1087)
KenCausey
03-10-11 17:34

However, as before in 0007358 I cannot reproduce this.

squeak/4.2-all-in-1$ ./Contents/Linux-i686/bin/squeak -version
4.4.7-2357 #1 XShm Sun Jan 23 18:17:31 PST 2011 gcc 4.3.2
Linux vps2.piumarta.com 2.6.18-028stab053.10-ent #1 SMP Thu Feb 28 20:34:08 MSK 2008 i686 GNU/Linux
plugin path: /home/ken/Projects/squeak/4.2-all-in-1/Contents/Linux-i686/lib/squeak/4.4.7-2357 [default: /home/ken/Projects/squeak/4.2-all-in-1/Contents/Linux-i686/lib/squeak/4.4.7-2357/]

squeak/4.2-all-in-1$ uname -a
Linux neue 2.6.32-5-amd64 #1 SMP Wed Jan 12 03:40:32 UTC 2011 x86_64 GNU/Linux

squeak/4.2-all-in-1$ cat /etc/debian_version
wheezy/sid

I tested all of sergio's examples and I get no crashes.

sergio: note how I got the squeak VM version info above. Could you provide that?

When did you download the all-in-one? I did so a couple of weeks ago, 2/28/11 I believe.
 
(0014063 - 224 - 236 - 236 - 344 - 344 - 344)
KenCausey
03-10-11 17:42

It occurs to me that if this is the same as 0007358, the issue depends on whether libuuid is installed on the system, I think. Or perhaps the version... I'm not sure.

dpkg -l '*uuid*' returns 'libuuid1 2.17.2-9.1' for me.
 
(0014064 - 760 - 850 - 850 - 850 - 850 - 850)
sergio
03-10-11 18:45

$ uname -a
Linux bagira 2.6.26-core2-ll #1 PREEMPT Sun Jan 30 14:48:45 EET 2011 x86_64 GNU/Linux

$ ./Contents/Linux-i686/bin/squeak -version
4.4.7-2357 #1 XShm Sun Jan 23 18:17:31 PST 2011 gcc 4.3.2
Linux vps2.piumarta.com 2.6.18-028stab053.10-ent #1 SMP Thu Feb 28 20:34:08 MSK 2008 i686 GNU/Linux
plugin path: /home/sergio/.squeak/My Squeak/Squeak 4.2 All-in-One.app/Contents/Linux-i686/lib/squeak/4.4.7-2357 [default: /home/sergio/.squeak/My Squeak/Squeak 4.2 All-in-One.app/Contents/Linux-i686/lib/squeak/4.4.7-2357/]

$ cat /etc/debian_version
6.0

$ dpkg -l '*uuid*'
...trash skipped...
ii libuuid1 2.17.2-9

Note: Debian 6.0 is partially false: it is originally 5.0 partially upgraded, with old kernel and X.
 
(0014065 - 277 - 307 - 307 - 307 - 307 - 307)
sergio
03-10-11 18:52

Hm... There is also squeak-vm installed from Debian repos.
This one:
ii squeak-vm 1:4.0.3.2202-2
Can it interfere in somewhat way with new unzipped filetree?

At least colourful/uniform windows may be switched in that old version without crash.
 
(0014066 - 59 - 59 - 59 - 59 - 59 - 59)
sergio
03-10-11 19:01

Add: Squeak-4.2-All-in-One.zip was downloaded two days ago.
 
(0014067 - 146 - 146 - 146 - 146 - 146 - 146)
lewis
03-11-11 00:54

This is the Linux libuuid bug, see issue 7358. Workaround is to delete the plugin, and a prophylactic fix has been proposed, see 7358 for details.
 
(0014068 - 156 - 156 - 156 - 156 - 156 - 156)
lewis
03-11-11 00:57

Closing issue as duplicate entry. Issue 7358 will retain a link to this report. Further details or comments should be entered in 7358. Thanks for reporting!
 

- Issue History
Date Modified Username Field Change
03-10-11 11:33 sergio New Issue
03-10-11 11:33 sergio Status new => assigned
03-10-11 11:33 sergio Assigned To  => KenCausey
03-10-11 11:44 sergio Note Added: 0014059
03-10-11 11:56 sergio File Added: oncrash_console_output.tar.bz2
03-10-11 17:25 KenCausey Relationship added duplicate of 0007358
03-10-11 17:26 KenCausey Note Added: 0014061
03-10-11 17:34 KenCausey Note Added: 0014062
03-10-11 17:39 KenCausey Assigned To KenCausey => lewis
03-10-11 17:39 KenCausey Category Any => VM
03-10-11 17:42 KenCausey Note Added: 0014063
03-10-11 18:45 sergio Note Added: 0014064
03-10-11 18:52 sergio Note Added: 0014065
03-10-11 19:01 sergio Note Added: 0014066
03-11-11 00:54 lewis Note Added: 0014067
03-11-11 00:54 lewis Status assigned => acknowledged
03-11-11 00:57 lewis Status acknowledged => closed
03-11-11 00:57 lewis Note Added: 0014068
03-11-11 00:57 lewis Resolution open => fixed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
80 total queries executed.
51 unique queries executed.
Powered by Mantis Bugtracker