Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000764 [Squeak] Any minor always 12-29-04 04:12 06-17-05 16:01
Reporter HernanTylim View Status public  
Assigned To gokr
Priority normal Resolution open  
Status closed   Product Version
Summary 0000764: [BUG][FIX] Global Flaps Fix
Description preamble:
This is a .cs with only a postscript that will reinstate the global flaps on Squeak 3.8 (and 3.9).

I must say that I don't know if how I am doing it is the right way to do it, but I figured that if after all this months nobody else tried to fix this problem then I should make an attempt to it.
Additional Information
Attached Files  GlobalFlapsFix-hpt.3.cs [^] (1,340 bytes) 12-29-04 04:12
 GlobalFlapsFix-hpt.4.cs [^] (802 bytes) 01-09-05 05:34

- Relationships
child of 0007212new  Mother for flaptab issues 

- Notes
(0001040 - 555 - 613 - 613 - 613 - 613 - 613)
ScottWallace
01-09-05 05:03

(1) There is a single method that reestablishes default flaps -- simply call "Flaps reinstateDefaultFlaps".
(2) However, flaps should never unconditinally be reinitialized by the postscript of an update, because some users have personalized flaps in their images that they do *not* want messed with! There is a preference governing this, namely "okToReinitializeFlaps". So a suitable do-it in the postscript of an update for restoring the standard flaps should be simply:

    Preferences okToReinitializeFlaps ifTrue: [Flaps reinstateDefaultFlaps]
 
(0001041 - 316 - 316 - 316 - 316 - 316 - 316)
HernanTylim
01-09-05 05:38

Ok. I followed Scott Wallace sugestion and uploaded a new .cs, but take into account that #reinstateDefaultFlaps removes the Navigator flaps and doesn't put it back. But because it is worse to not have all the global flaps that to only lack the Navigator flap I think that this .cs should be included on 3.8 and 3.9.
 
(0001043 - 1616 - 1870 - 1870 - 1870 - 1870 - 1870)
ScottWallace
01-09-05 11:11

Actually, reinstateDefaultFlaps *does* create a Navigator flap in 3.8. If you bring up the "flaps" menu after you execute "Flaps reinstateDefaultFlaps", you'll see the Navigator there in the list, it's just that it's disabled -- but it can be readily enabled by toggling its checkbox. (The assumption here has been that the etoy community wanted to see the Navigator by default but the squeak-dev community did not.)

If it were now decided that the Navigator should be *showing* in the default flap setup, one could patch #reinstateDefaultFlaps by commenting out the line that disables the Navigator.

*Important* Matters are different in 3.9a, because, due to a bug in the "big bang" code, specifically in method Flaps.addStandardFlaps, as changed in update 6403NewUIBingBang-dgd, the navigator flap does not get created when it should.

This bug needs to be fixed! It presumably arises from a misunderstanding of the meaning of the "showProjectNavigator" Preference (which actually does not *not* relate to the "Navigator" flap), which results in the Navigator flap not getting created by the init code.

The fix is to remove the "Preferences showProjectNavigator" guard clauses in #addStandardFlaps, so that instead of reading

    Preferences showProjectNavigator
        ifTrue: [SharedFlapTabs add: self newNavigatorFlap].

we would simply have an unconditional

    SharedFlapTabs add: self newNavigatorFlap

... again, this latter fix is just for a bug new to 3.9a. But that needs to be fixed in 3.9a before the do-it to reinstate default flaps is issued there, in order to obtain the Navigator.
 
(0001197 - 190 - 190 - 190 - 190 - 190 - 190)
gokr
02-28-05 16:06

Ok, I think then the second version is good for inclusion in 3.8, but possibly in the new ReleaseBuilder methods. I will see to that, and also make sure the fix Scott mentions gets into 3.9.
 
(0001643 - 12 - 12 - 12 - 12 - 12 - 12)
MarcusDenker
06-17-05 16:01

fixed in 3.8
 

- Issue History
Date Modified Username Field Change
12-29-04 04:12 HernanTylim New Issue
12-29-04 04:12 HernanTylim File Added: GlobalFlapsFix-hpt.3.cs
12-29-04 19:33 HernanTylim Issue Monitored: HernanTylim
01-09-05 05:03 ScottWallace Note Added: 0001040
01-09-05 05:34 HernanTylim File Added: GlobalFlapsFix-hpt.4.cs
01-09-05 05:38 HernanTylim Note Added: 0001041
01-09-05 11:11 ScottWallace Note Added: 0001043
01-10-05 08:58 ScottWallace Status new => assigned
01-10-05 08:58 ScottWallace Assigned To  => ScottWallace
01-10-05 09:53 ScottWallace Assigned To ScottWallace =>
02-28-05 16:04 gokr Assigned To  => gokr
02-28-05 16:06 gokr Note Added: 0001197
06-17-05 16:01 MarcusDenker Status assigned => closed
06-17-05 16:01 MarcusDenker Note Added: 0001643
10-13-08 02:24 wiz Relationship added child of 0007212


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
67 total queries executed.
42 unique queries executed.
Powered by Mantis Bugtracker