Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007654 [Squeak] VM feature always 07-29-11 22:48 02-24-13 14:53
Reporter lewis View Status public  
Assigned To lewis
Priority normal Resolution open  
Status closed   Product Version
Summary 0007654: Add Scratch plugins CameraPlugin and ScratchPlugin to standard VMs
Description The Scratch project (scratch.mit.edu) provides two plugins that should be made available for standard VMs. The ScratchPlugin is useful for running a Scratch image (although the Scratch image, based on Squeak 3.6, may require updates). The CameraPlugin is of general interest and is useful on both standard and Cog VMs.

These plugins have been released under MIT license in order to enable inclusion in standard VMs. Supporting platform libraries (e.g. DirectShow on Windows) are separately licensed and not provided under MIT.
Additional Information Per communication from Bert Freudenberg, source for CameraPlugin is now available under MIT license:

From: Bert Freudenberg <bert@freudenbergs.de>
Subject: Fwd: CameraPlugin
Date: Fri, 29 Jul 2011 22:08:54 +0200
To: "David T. Lewis" <lewis@mail.msen.com>
 
Begin forwarded message:
 
> From: Bert Freudenberg <bert@freudenbergs.de>
> Date: 28. Mai 2010 20:31:28 MESZ
> To: Andreas Raab <andreas.raab@gmx.de>, John McIntosh <johnmci@smalltalkconsulting.com>, Ian Piumarta <piumarta@speakeasy.net>
> Subject: Fwd: CameraPlugin
>
> So here is the CameraPlugin, too, under MIT :)
>
> - Bert -
>
>
> Begin forwarded message:
>
>> From: John Maloney <jmaloney@media.mit.edu>
>> Date: 28. Mai 2010 20:16:15 MESZ
>> To: Bert Freudenberg <bert@freudenbergs.de>
>> Subject: Re: CameraPlugin
>>
>> Hi, Bert.
>>
>> Derek had been asking about the ScratchPlugin, so I thought that's what you were asking for...
>>
>> Here is the CameraPlugin code under MIT license. Note that the Windows DirectShow classes and libraries are included only as a convenience. That code is not covered by the MIT license for the CameraPlugin (obviously). As recall, it was a tedious and painful process to figure out how to install DirectShow and set up the proper build environment on Windows. I've included the compiled DLL and some notes. (I suspect that using the camera under Windows has gotten easier since I first made this plugin.)
>>
>> -- John
>>

[-- Attachment 0000002: CameraPlugin.zzp --]
Attached Files  CameraPlugin.zip [^] (393,341 bytes) 07-29-11 22:48

- Relationships

SYSTEM WARNING: Creating default object from empty value

related to 0007815assigned lewis Complete the integration of Scratch plugins for all platforms and VMs 
related to 0007816assigned lewis Update CameraPlugin for 64-bit VM 

- Notes
(0014245 - 196 - 208 - 208 - 208 - 208 - 208)
lewis
08-08-12 12:04

Bert has added the four Scratch-related plugins to VMMaker trunk, and Ian has added the Unix support code to SVN.

The new plugins are CameraPlugin, ScratchPlugin, WeDoPlugin, and UnicodePlugin.
 

- Issue History
Date Modified Username Field Change
07-29-11 22:48 lewis New Issue
07-29-11 22:48 lewis Status new => assigned
07-29-11 22:48 lewis Assigned To  => lewis
07-29-11 22:48 lewis File Added: CameraPlugin.zip
08-08-12 12:04 lewis Note Added: 0014245
08-08-12 12:04 lewis Status assigned => testing
02-24-13 14:53 lewis Status testing => closed
04-03-14 22:18 lewis Relationship added related to 0007815
04-05-14 15:41 lewis Relationship added related to 0007816


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
47 total queries executed.
33 unique queries executed.
Powered by Mantis Bugtracker