Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007657 [Spoon] crash always 08-16-11 18:20 08-30-11 19:21
Reporter craig View Status public  
Assigned To craig
Priority urgent Resolution fixed  
Status feedback  
Summary 0007657: Flow plugin fails to load for Spoon 3 alpha 1 on some MacOS systems
Description On some Macs, the Flow VM plugin doesn't load properly. That's fatal
because it contains a corrected version of the idle-loop's relinquish
primitive (required for headless remote messaging to work at a decent
speed), and the headful UI depends on that primitive working properly.

We need info about this from affected users (from stdout, gdb, XCode, etc.,
as much host-OS info as is available). Craig can't reproduce this on his
Mac (early-2009 MBP, 10.6.8).
Additional Information
Attached Files

- Relationships

- Notes
(0014174 - 145 - 157 - 157 - 157 - 157 - 157)
craig
08-16-11 18:50
edited on: 08-16-11 19:02

Bert noticed from 'otool' output that another library that Flow uses was missing (portmidi, it was in Craig's /usr/local/lib). Will fix in 3a2.

 
(0014176 - 305 - 341 - 341 - 341 - 341 - 341)
craig
08-17-11 23:24

Fixed in 3a2.

I corrected the Flow plugin for the Mac; it uses a dynamic library
(portmidi) that was loaded on my machine from /usr/local/lib/. Now it
loads from the Resources folder for the Flow plugin. This involved
'install_name_tool' and a plugin rebuild. Thanks to Bert for mentioning
'otool'.
 
(0014181 - 114 - 160 - 160 - 160 - 160 - 160)
craig
08-30-11 19:21

Edgar reports plugin load failure on "every machine I own". Edgar: please provide OS details?

Thanks,

-C

 

- Issue History
Date Modified Username Field Change
08-16-11 18:20 craig New Issue
08-16-11 18:50 craig Note Added: 0014174
08-16-11 19:02 craig Note Edited: 0014174
08-17-11 23:24 craig Status new => resolved
08-17-11 23:24 craig Resolution open => fixed
08-17-11 23:24 craig Assigned To  => craig
08-17-11 23:24 craig Note Added: 0014176
08-30-11 19:20 craig Status resolved => assigned
08-30-11 19:21 craig Note Added: 0014181
08-30-11 19:21 craig Status assigned => feedback


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
47 total queries executed.
33 unique queries executed.
Powered by Mantis Bugtracker