Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007678 [Squeak] Tools minor always 11-16-11 05:14 12-06-11 14:49
Reporter jgon View Status public  
Assigned To leves
Priority normal Resolution fixed  
Status resolved   Product Version trunk
Summary 0007678: Pressing enter in an empty selector browser that has been edited brings up a debugger
Description When using the selector browser you can enter text in the search field and the field will be marked as edited. If you then delete all of the text out of the search field it will still be marked as edited, and if you hit enter to accept the search a debugger will pop up.

This happens because the contents:notifying: method does not guard against getting a list of tokens that is empty.
Additional Information My fix for this issue just does the simplest thing, which is guard against an empty list of tokens. Not knowing much about the selector browser I am not sure if there is a better fix for this.
Attached Files  Tools-jmg.386.mcz [^] (540,238 bytes) 11-16-11 05:14

- Relationships

- Notes
(0014202 - 144 - 144 - 144 - 144 - 144 - 144)
leves
12-06-11 14:49

Fixed in Tools-ul.386. The bug also occured when the input consisted only of whitespaces, so the easiest solution was to trim unnecesary blanks.
 

- Issue History
Date Modified Username Field Change
11-16-11 05:14 jgon New Issue
11-16-11 05:14 jgon File Added: Tools-jmg.386.mcz
12-06-11 14:49 leves Status new => resolved
12-06-11 14:49 leves Fixed in Version  => trunk
12-06-11 14:49 leves Resolution open => fixed
12-06-11 14:49 leves Assigned To  => leves
12-06-11 14:49 leves Note Added: 0014202


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
38 total queries executed.
31 unique queries executed.
Powered by Mantis Bugtracker