Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007691 [Squeak] VM major always 04-27-12 12:24 04-28-12 00:32
Reporter lewis View Status public  
Assigned To lewis
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0007691: JPEGReadWriter2Plugin off-by-one bug crashes VM
Description Fix for an off-by-one bug is provided on vm-dev:

http://lists.squeakfoundation.org/pipermail/vm-dev/2012-April/010470.html [^]

Diagnosed and fixed by Páhi András pahia at t-online.hu
Confirmed by Juan Vuletich
Additional Information Fix is for the generated plugin (VMMaker), provided as C code. Need to incorporate back into the SLANG.
Attached Files  JPEGReadWriter2Plugin.c [^] (21,420 bytes) 04-27-12 12:28

- Relationships

- Notes
(0014223 - 574 - 670 - 764 - 764 - 764 - 764)
lewis
04-27-12 12:28

From: P?hi Andr?s <pahia@t-online.hu>
To: <vm-dev@lists.squeakfoundation.org>
Date: Fri, 27 Apr 2012 10:02:43 +0200
Subject: [Vm-dev] JPEGReadWriter2Plugin crash fixed

Hi,

I have found the origin of various crashes in the Squeak VM, which is related to the JPEGReadWriter2Plugin.
The hunt begun with Juan's Cuis 4.0 release, see the emails exchanged below and the description.

I have attached the fixed C source, but the fix should go in the VM sources, because the code is
generated as I see. Please include the fix in the VM sources.

Regards,
Andras Pahi
 
(0014224 - 776 - 854 - 854 - 854 - 854 - 854)
lewis
04-28-12 00:30

This bug was fixed by John McIntosh and incorporated into VMMaker in Oct 2010, but is not yet merged into the Cog branch. Need to update the oscog branch with changes from trunk VMM. A number of changes for JPEG plugin were merged from oscog in VMMaker-dtl.191, then John's changes were added in VMMaker-dtl.192. John's changes need to be added back to oscog. The VMMaker commit was here:

Name: VMMaker-dtl.192
Author: dtl
Time: 9 October 2010, 2:26:51 am
UUID: e22782de-efc8-4029-b1ec-61588fb91d37
Ancestors: VMMaker-dtl.191

VMMaker 4.3.6

Merge John's 64-bit changes for JPEGReaderWriter2Plugin.
Add unit tests based on Bert's test in original bug report.

With these patches JPEGReaderWriter2Plugin works with the VM compiled in either 32-bit or 64-bit mode.
 
(0014225 - 130 - 130 - 130 - 130 - 130 - 130)
lewis
04-28-12 00:32

Bug was resolved by John McIntosh, added to VMMaker in 2010. John's update needs to be incorporated into oscog branch for Cog VMs.
 

- Issue History
Date Modified Username Field Change
04-27-12 12:24 lewis New Issue
04-27-12 12:24 lewis Status new => assigned
04-27-12 12:24 lewis Assigned To  => lewis
04-27-12 12:28 lewis Note Added: 0014223
04-27-12 12:28 lewis File Added: JPEGReadWriter2Plugin.c
04-28-12 00:30 lewis Note Added: 0014224
04-28-12 00:31 lewis Status assigned => resolved
04-28-12 00:31 lewis Resolution open => fixed
04-28-12 00:32 lewis Note Added: 0014225


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
45 total queries executed.
33 unique queries executed.
Powered by Mantis Bugtracker