Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007716 [Squeak] VM minor always 01-12-13 01:00 06-08-16 00:17
Reporter lewis View Status public  
Assigned To lewis
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0007716: Harvest HostWindowPlugin enhancements from Qwaq/Teleplace (now 3d ICC)
Description As noted by Eliot Miranda:
An additional piece of history is that a number of plugins, including
the HostWindowPlugin, were enhanced at Qwaq/Teleplace (now 3d ICC), in a
cross-platform manner since we supported Mac and Windows initially and
later had a linux prototype. The code for some of these enhanced plugins,
including the HostWindowPlugin, was released along with Cog, which has an
MIT license. So if you mine the COg branch you'll find code that can be
folded back into trunk you'll get the enhanced functionality. For the
Qwaq/Teleplace HostWindowPlugin that included setting the window title,
repositioning and resizing the main window, querying its size, etc.
Additional Information Discussed here: http://lists.squeakfoundation.org/pipermail/vm-dev/2013-January/011799.html [^]
Attached Files

- Relationships

- Notes
(0014590 - 138 - 138 - 138 - 138 - 138 - 138)
lewis
06-08-16 00:17

The key enhancements are now in the trunk and oscog VM branches, and the X11 host window support works for the main Squeak display window.
 

- Issue History
Date Modified Username Field Change
01-12-13 01:00 lewis New Issue
01-12-13 01:00 lewis Status new => assigned
01-12-13 01:00 lewis Assigned To  => lewis
06-08-16 00:17 lewis Status assigned => resolved
06-08-16 00:17 lewis Resolution open => fixed
06-08-16 00:17 lewis Note Added: 0014590


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
35 total queries executed.
29 unique queries executed.
Powered by Mantis Bugtracker