Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007726 [Squeak] Installer minor always 01-26-13 22:25 02-27-13 11:35
Reporter FrankShearar View Status public  
Assigned To FrankShearar
Priority normal Resolution fixed  
Status resolved   Product Version trunk
Summary 0007726: Installer doesn't trim package names of whitespace
Description Installer squeakmap
  addPackage: 'OSProcess (4.4.11)';
  install

fails because 'OSProcess ' is not in the cached catalog.
Additional Information Possibly it's sufficient to change the search condition in SMSqueakMap >> #packageWithName:ifAbsent: to strip whitespace?
Attached Files

- Relationships

- Notes
(0014308 - 50 - 50 - 50 - 50 - 50 - 50)
FrankShearar
01-28-13 19:27

Installer-Core.fbs.361 and Tests-fbs.187 in trunk.
 
(0014326 - 58 - 58 - 58 - 58 - 58 - 58)
FrankShearar
02-27-13 11:35

Installer-Core-fbs.361 in Trunk looks like it did the job.
 

- Issue History
Date Modified Username Field Change
01-26-13 22:25 FrankShearar New Issue
01-26-13 22:25 FrankShearar Status new => assigned
01-26-13 22:25 FrankShearar Assigned To  => KenCausey
01-26-13 22:29 FrankShearar Assigned To KenCausey => FrankShearar
01-26-13 22:29 FrankShearar Summary Installer dosen't trim package names => Installer dosen't trim package names of whitespace
01-26-13 22:33 KenCausey Category Any => Installer
01-26-13 22:50 FrankShearar Summary Installer dosen't trim package names of whitespace => Installer doesn't trim package names of whitespace
01-28-13 19:27 FrankShearar Status assigned => testing
01-28-13 19:27 FrankShearar Note Added: 0014308
02-27-13 11:35 FrankShearar Status testing => resolved
02-27-13 11:35 FrankShearar Resolution open => fixed
02-27-13 11:35 FrankShearar Note Added: 0014326


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
45 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker