Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007790 [Squeak] Any major always 10-08-13 01:26 10-08-13 01:28
Reporter tim View Status public  
Assigned To tim
Priority urgent Resolution fixed  
Status closed   Product Version 4.4
Summary 0007790: Raspberry Pi related faster bitblt code problem with tallyIntoMap combination rule
Description Reported issue was some PNG file provided as media of Scratch suddenly loading as invisible sprites.

Debugging the image showed a problem in the colorReduced method because the tallyIntoMap bitblt rule was producing incorrect values. After much staring at code we discovered a minuscule typo that had a constant in BitBltSimulation>>copyBits:Fallback: as 16r3FFF instead of 16r7FFF and thus the cmMask value used to write into the map array was wrong.
Additional Information Fixed in VMMaker-tpr.326
Attached Files

- Relationships

- Notes
(0014464 - 14 - 14 - 14 - 14 - 14 - 14)
tim
10-08-13 01:28

All better now
 

- Issue History
Date Modified Username Field Change
10-08-13 01:26 tim New Issue
10-08-13 01:26 tim Status new => assigned
10-08-13 01:26 tim Assigned To  => KenCausey
10-08-13 01:27 tim Assigned To KenCausey => tim
10-08-13 01:28 tim Status assigned => resolved
10-08-13 01:28 tim Fixed in Version  => 4.4
10-08-13 01:28 tim Resolution open => fixed
10-08-13 01:28 tim Note Added: 0014464
10-08-13 01:28 tim Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
39 total queries executed.
31 unique queries executed.
Powered by Mantis Bugtracker