Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007837 [Squeak] VM minor always 11-07-15 02:17 11-15-15 23:54
Reporter lewis View Status public  
Assigned To lewis
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0007837: SocketPlugin connect on a UDP socket does not perform the connect() call on Unix VM
Description Socket connect on a UDP socket does not do the connect() call on Unix VM. This prevents query of the resulting socket to determine local IP address, which is needed to determine the IPV4 address that an external system may use to connect to the local system.

Discussion at http://lists.squeakfoundation.org/pipermail/vm-dev/2015-September/019419.html [^]

The actual call to connect() is missing from sqSocketConnectToPort() and sqSocketConnectToAddressSize() for the case of UDP sockets. Adding the call seems to produce the expected results. Verify by evaluating the following to find a local IP V4 address:

| s local |
s := Socket newUDP setPeer: (NetNameResolver addressForName: '8.8.8.8') port: 0.l.
local := s localAddress.
s close.
local "==> #[172 16 0 10]"
Additional Information
Attached Files  sqUnixSocket.c.diff [^] (941 bytes) 11-07-15 02:25
 sqUnixSocket.c [^] (57,808 bytes) 11-07-15 02:26

- Relationships
duplicate of 0007834closed lewis SocketPlugin 

- Notes
(0014552 - 31 - 31 - 31 - 31 - 31 - 31)
lewis
11-07-15 02:26

Patched file and diff attached.
 
(0014562 - 44 - 44 - 44 - 44 - 44 - 44)
lewis
11-15-15 23:54

Patch applied to SVN trunk and oscog branch.
 

- Issue History
Date Modified Username Field Change
11-07-15 02:17 lewis New Issue
11-07-15 02:17 lewis Status new => assigned
11-07-15 02:17 lewis Assigned To  => lewis
11-07-15 02:18 lewis Relationship added duplicate of 0007834
11-07-15 02:25 lewis File Added: sqUnixSocket.c.diff
11-07-15 02:26 lewis File Added: sqUnixSocket.c
11-07-15 02:26 lewis Note Added: 0014552
11-15-15 23:54 lewis Status assigned => closed
11-15-15 23:54 lewis Note Added: 0014562
11-15-15 23:54 lewis Resolution open => fixed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
48 total queries executed.
33 unique queries executed.
Powered by Mantis Bugtracker