Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000851 [Squeak] Morphic minor always 01-29-05 09:05 11-28-06 04:33
Reporter wiz View Status public  
Assigned To
Priority normal Resolution reopened  
Status feedback   Product Version
Summary 0000851: [Fix] BalloonRectangleMorph sampleInstance doesn't fully initialize.
Description To get this bug requeast a BalloonRectangleMorph sampleInstance (I used the menus sample instance). It chokes because the gradient fill origin does not get initialized. Modifing
OrientedFill>>origin
^ origin ifNil: [ 0@0 ]
allows it to work.
Additional Information See also 0000833 for related fill bug fix.

Also this is only a partial fix. The red button menu for the sample instance fails to come up because borderstyle can't perform gradient fill styles.
I choose to leave that for someone else to fix.
Attached Files  OrientedFillStyle-origin.st.gz [^] (202 bytes) 01-29-05 09:05
 BalloonRectSample.jpeg [^] (2,724 bytes) 01-29-05 09:06
 BalloonRectMorph-wiz.1.cs [^] (517 bytes) 02-01-05 23:09
 BalloonRectMangle2.jpeg [^] (8,117 bytes) 02-01-05 23:21
 BalloonRectMangle3.jpeg [^] (8,263 bytes) 02-01-05 23:21
 BalloonEllipseMangled.jpeg [^] (2,966 bytes) 02-01-05 23:34
 TestSampleInstances.st [^] (864 bytes) 11-28-06 04:30

- Relationships

- Notes
(0001109 - 87 - 87 - 87 - 87 - 87 - 87)
wiz
01-29-05 09:07

I've also included a snapshot of the Sample instance so you can see what your missing.
 
(0001125 - 732 - 780 - 780 - 915 - 915 - 915)
wiz
02-01-05 23:33

BalloonRectMorph-wiz.1.cs allows a sample instance to be gotten by reverting simple border. I simply removed dgd's too fancy gradient defaultBorderColor.

Playing with this sample other bug emerge as the morph is rotated.
The rotated form only looks right at 90 degree headings.
Also subsequent uses of the blue rotation handle seem to layer the morph into deeper layers of MatrixTransformMorph. MTM is not a good citizen for halo yet.

Getting a fresh Balloon rectange. Embedding a (transparent) ellipse in it and starting to rotate but not actually rotating it produced a manling of the ellipse border remenicent of the mangling that happens when you use a gradient fill in a similar ellipse. Hmmm.

See related 0000857.
 
(0001136 - 761 - 827 - 827 - 827 - 827 - 827)
wiz
02-06-05 06:28

The gradient fill strangeness in BalloonRectMangle2.jpg seems to be a property of radial gradient fill.

From the experiments I've been making the follow seems to be true.
if direction is allong the x or y axis then normal can be scaled and the result is a correct appearing elliptical radial fill.

Setting direction to any point then setting normal to nil to force recomputation always results in a correctly appearing circular radial fill.

Scaling the normal by more than a little will result in distortion.

The distortion looks like it depends on what quadrant or octant is being drawn.

I've been wondering what the balloon drawing routines are doing and if in some places direction and normal 's x and y 's are getting mixed up and confused.
 
(0001147 - 57 - 57 - 57 - 180 - 180 - 180)
wiz
02-13-05 04:09

see 0000877 for illumination on the radial gradient bug.
 
(0002326 - 6 - 6 - 6 - 6 - 6 - 6)
MarcusDenker
08-13-05 01:33

in 3.9
 
(0008451 - 427 - 511 - 511 - 511 - 511 - 511)
wiz
11-28-06 01:28
edited on: 11-28-06 01:29

Though this has been marked fixed the fix is not in 7067.

In particular the method
OrientedFill>>origin has reverted.

Once that is fixed the sampleinstance will appear.

To get this bug request a BalloonRectangleMorph sampleInstance (I used the menus sample instance). It chokes because the gradient fill origin does not get initialized. Modifing
OrientedFill>>origin
^ origin ifNil: [ 0@0 ]
allows it to work.

 
(0008452 - 231 - 255 - 255 - 255 - 255 - 255)
wiz
11-28-06 04:33

TestSampleInstances.st will test to see if BalloonRectangleMorph will open when sampleInstance is requested of it.

Fails in 6076 until OrientedFillStyle-origin.st.gz is loaded then it passes.

Yours in service, --Jerome Peace
 

- Issue History
Date Modified Username Field Change
01-29-05 09:05 wiz New Issue
01-29-05 09:05 wiz File Added: OrientedFillStyle-origin.st.gz
01-29-05 09:06 wiz File Added: BalloonRectSample.jpeg
01-29-05 09:07 wiz Note Added: 0001109
02-01-05 23:09 wiz File Added: BalloonRectMorph-wiz.1.cs
02-01-05 23:21 wiz File Added: BalloonRectMangle2.jpeg
02-01-05 23:21 wiz File Added: BalloonRectMangle3.jpeg
02-01-05 23:33 wiz Note Added: 0001125
02-01-05 23:34 wiz File Added: BalloonEllipseMangled.jpeg
02-06-05 06:28 wiz Note Added: 0001136
02-13-05 04:09 wiz Note Added: 0001147
08-13-05 01:33 MarcusDenker Status new => closed
08-13-05 01:33 MarcusDenker Note Added: 0002326
11-28-06 01:28 wiz Status closed => feedback
11-28-06 01:28 wiz Resolution open => reopened
11-28-06 01:28 wiz Note Added: 0008451
11-28-06 01:29 wiz Note Edited: 0008451
11-28-06 04:30 wiz File Added: TestSampleInstances.st
11-28-06 04:33 wiz Note Added: 0008452


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
79 total queries executed.
44 unique queries executed.
Powered by Mantis Bugtracker