Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000908 [Squeak Packages] Universes tweak always 02-28-05 22:25 09-23-07 08:13
Reporter KenCausey View Status public  
Assigned To lexspoon
Priority normal Resolution fixed  
Status resolved  
Summary 0000908: [ENH] UniversePackageCaching
Description "Change Set: UniversePackageCaching
Date: 24 February 2005
Author: Tony Garnock-Jones

Split out the downloading and caching part of UPackage>>install into
UPackage>>cachedCopyFilename. Added UUniverse>>buildPackageCache which
takes advantage of this to flesh out a local copy of a particular
universe."!

from: tonyg@lshift.net
Additional Information I installed this changeset on top of Universes (9) (from SqueakMap) in a 3.7 image

The refactored code worked as before in a Universes Browser. It also added a method buildPackageCache to class UUniverse that appeared to have no senders of its message. When I sent this message from an inspector it had the expected behaviour of downloading all of the packages in the Universe to a cache on the local machine.

(Original post by bjb in wrong project at id 902. Moved by KenCausey)
Attached Files  UniversePackageCaching.cs.gz [^] (815 bytes) 02-28-05 22:25

- Relationships
duplicate of 0000902closed  Squeak [ENH] UniversePackageCaching 

- Notes
(0010717 - 98 - 98 - 98 - 98 - 98 - 98)
lexspoon
05-13-07 16:13

This is nice. Somehow I overlooked the original report. I'll add it to Universes version ls.28 .
 
(0011183 - 18 - 18 - 18 - 18 - 18 - 18)
lexspoon
09-23-07 08:13

It's included now.
 

- Issue History
Date Modified Username Field Change
02-28-05 22:25 KenCausey New Issue
02-28-05 22:25 KenCausey File Added: UniversePackageCaching.cs.gz
02-28-05 22:28 KenCausey Additional Information Updated
03-02-05 20:07 KenCausey Relationship added duplicate of 0000902
05-13-07 16:13 lexspoon Note Added: 0010717
09-23-07 08:13 lexspoon Status new => resolved
09-23-07 08:13 lexspoon Resolution open => fixed
09-23-07 08:13 lexspoon Assigned To  => lexspoon
09-23-07 08:13 lexspoon Note Added: 0011183


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
48 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker