Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000919 [Squeak] Any feature always 03-04-05 09:15 08-29-05 16:16
Reporter gokr View Status public  
Assigned To dway
Priority high Resolution fixed  
Status closed   Product Version 3.8
Summary 0000919: We should have a question popping up to load post release fixes from the update stream if the image is "pristine".
Description The problem is that people unpack the release image and don't load updates - typically newbies don't even know how to. So if we discover serious post release bugs we want to put post release fixes into the release update stream and be sure that newbies get them.

In AutoStart there was already code for a pref to "load updates on startup". I added a class var and some more code with a specific message to the user. The result is that if we set the class var flag to true using:

   AutoStart setPristine: true

---the image will ask the user on startup about loading post release fixes since this is a "pristine image".

After having done that
Additional Information
Attached Files  pristineImage-gk.1.cs.gz [^] (1,474 bytes) 03-04-05 09:17
 loadUpdatesTweak-dew.cs.gz [^] (1,213 bytes) 03-06-05 06:56

- Relationships

- Notes
(0001227 - 71 - 71 - 71 - 71 - 71 - 71)
gokr
03-04-05 14:39

Ok, a simpler variant went in in update 6598, so this should be solved.
 
(0001232 - 436 - 466 - 670 - 670 - 670 - 670)
dway
03-06-05 06:54

I posted some followup to this on squeak-dev. Basically just tweaking this changeset a bit more to make it hopefully even clearer for beginners, and fixing a couple of typos.

http://lists.squeakfoundation.org/pipermail/squeak-dev/2005-March/089557.html [^]

I'm not sure if reopening this issue is strictly necessary, but I wanted to play a bit more with Mantis. ;) I'll assign it to myself so that I make sure it gets followed up.
 
(0002566 - 66 - 66 - 66 - 66 - 66 - 66)
laza
08-29-05 15:40

The latest version from Doug seems to be in effect in 3.8 and 3.9.
 
(0002567 - 4 - 4 - 4 - 4 - 4 - 4)
MarcusDenker
08-29-05 16:14

done
 

- Issue History
Date Modified Username Field Change
03-04-05 09:15 gokr New Issue
03-04-05 09:16 gokr Status new => assigned
03-04-05 09:16 gokr Assigned To  => gokr
03-04-05 09:17 gokr File Added: pristineImage-gk.1.cs.gz
03-04-05 14:39 gokr Status assigned => closed
03-04-05 14:39 gokr Note Added: 0001227
03-06-05 06:54 dway Note Added: 0001232
03-06-05 06:54 dway Assigned To gokr => dway
03-06-05 06:54 dway Status closed => assigned
03-06-05 06:56 dway File Added: loadUpdatesTweak-dew.cs.gz
08-29-05 15:40 laza Status assigned => resolved
08-29-05 15:40 laza Fixed in Version  => 3.8
08-29-05 15:40 laza Resolution open => fixed
08-29-05 15:40 laza Note Added: 0002566
08-29-05 16:14 MarcusDenker Status resolved => closed
08-29-05 16:14 MarcusDenker Note Added: 0002567


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
59 total queries executed.
39 unique queries executed.
Powered by Mantis Bugtracker