Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000938 [tweak] Any minor always 03-09-05 14:43 04-25-05 23:24
Reporter grit View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved  
Summary 0000938: [Mac] the mouse wheel doesn't work in tweak
Description the mouse wheel doesn't work for scrolling in tweak text windows and browsers
The problem appears to be that no up/down events are generated by scrolling, but only stroke events
Additional Information
Attached Files

- Relationships

- Notes
(0001243 - 110 - 110 - 110 - 110 - 110 - 110)
bert
03-09-05 22:02

At least not in the Mac VM which does not produce key up/down events for scrolling, but only key stroke events
 
(0001245 - 99 - 99 - 99 - 99 - 99 - 99)
andreas
03-10-05 04:26

Really? I just fixed this a while ago (and verified it just now on 3.8). Which platform is this on?
 
(0001250 - 65 - 65 - 65 - 65 - 65 - 65)
grit
03-10-05 10:42

Ok, I'm still working on 3.7 - this could be the reason, why :#)
 
(0001382 - 29 - 29 - 29 - 29 - 29 - 29)
corny
04-18-05 09:16

same goes for the Windows 3.8
 
(0001431 - 188 - 188 - 188 - 188 - 188 - 188)
andreas
04-25-05 23:24

Okay, found and fixed it. Turns out that mouse-wheel events are reported as keystrokes not keydown events; therefore we need a workaround until the VMs are fixed (if that ever happens...).
 

- Issue History
Date Modified Username Field Change
03-09-05 14:43 grit New Issue
03-09-05 22:02 bert Note Added: 0001243
03-10-05 04:26 andreas Note Added: 0001245
03-10-05 04:26 andreas Status new => feedback
03-10-05 10:42 grit Note Added: 0001250
03-17-05 10:43 bert Status feedback => new
03-17-05 10:43 bert Summary the mouse wheel doesn't work in tweak => [Mac] the mouse wheel doesn't work in tweak
03-17-05 10:43 bert Description Updated
04-18-05 09:16 corny Note Added: 0001382
04-25-05 23:24 andreas Status new => resolved
04-25-05 23:24 andreas Resolution open => fixed
04-25-05 23:24 andreas Assigned To  => andreas
04-25-05 23:24 andreas Note Added: 0001431
04-25-05 23:24 andreas Assigned To andreas =>


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
59 total queries executed.
41 unique queries executed.
Powered by Mantis Bugtracker