Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000987 [Squeak] Kernel minor always 03-16-05 09:27 08-04-05 23:55
Reporter BGaertner View Status public  
Assigned To laza
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0000987: Deprecated Integer>>hex has still some senders
Description This bug report is for Squeak 3.9alpha latest update: 0006599

Change set #6217 replaced Integer>>hex with storeStringHex and printStringHex.
Integer>>hex itself is now deprecated. However, there are still
18 senders of hex. The ZipArchiveViewer is among the more
important things that currently do not work.

Attached you find the proposal for a fix
Additional Information Note that the now deprecated hey answered a storeString (like 16r3F). Some
methods used (string allButFirst: 3) to remove the '16r'.
Attached Files  HexFixes.1.cs [^] (11,070 bytes) 03-16-05 09:27
 vwi.jpg [^] (8,323 bytes) 03-17-05 11:39

- Relationships

SYSTEM WARNING: Creating default object from empty value

related to 0000156closed ducasse [ENH] IntegerPrintOnPaddingAllInOne 
related to 0000996closed  A hack to make the ObjectExplorer display integers in hexadecimal, octal and binary form too. 
related to 0006339closed  Character>> hex method fails 

- Notes
(0001274 - 235 - 257 - 257 - 257 - 257 - 257)
laza
03-16-05 10:40

Hi Boris!

It's a while since I published the changeset and I'm pretty sure I did not find and replace every use of hex with storeStringHex in the accompanying "fix collateral damage" changeset back then. I will look into this today.
 
(0001279 - 295 - 416 - 416 - 416 - 416 - 416)
laza
03-17-05 10:14

CS looks good. I like the change not to display the prefix 16r in the FileList hex view.
Maybe Yoshiki can comment on:

MultiCharacter methodsFor: 'printing' stamp: 'BG 3/16/2005 08:25'
hex

    ^ value storeStringHex.
        "is this ok or is printStringHex the preferred writing form? "
 
(0001280 - 40 - 46 - 46 - 46 - 46 - 46)
laza
03-17-05 10:19

Reminder sent to: ohshima

Is the change in MultiCharacter>>hex ok?
 
(0001281 - 168 - 178 - 178 - 178 - 178 - 178)
bert
03-17-05 10:32

Eeek, why is this going away??? It's been a great debugging help to me. Why can't you just leave it in as shortcut for either of the longer versions? Just for "purity"?
 
(0001282 - 694 - 807 - 807 - 807 - 807 - 807)
laza
03-17-05 11:38

> It's been a great debugging help to me.
> Why can't you just leave it in as shortcut for either of the longer versions?

I would rather have an enhanced inspector for this like in VW instead. (see screenshot)
We could leave hex and hex8 (yuck!) deprecated and add a comment to them that would protect them from being purged on the next major release. Hopefully this would prevent the usage of hex* in actual code.

> Just for "purity"?

Now I think it is easier to read "4711 printStringHex" than "4711 hex allButFirst: 3" or worse. And hex is ambiguous. Should the result be "16rXYZ" or "XYZ"?
And if we want to be pragmatic why don't we introduce str as a shortcut for printString?
 
(0001285 - 238 - 266 - 266 - 266 - 266 - 266)
ohshima
03-18-05 03:23

So far, MultiCharacter>>hex has been just my own debugging support. The format was inconsistent with Character, but I didn't care.

  You can change it in any reasonable way, but I don't get why it should be removed, honestly speaking.
 
(0001286 - 463 - 493 - 493 - 637 - 637 - 637)
laza
03-18-05 10:22

Actually MultiChar>>hex isn't deprecated and just uses the deprecated Integer>>hex.
I don't like the selector hex or hex8 for the reasons I mentioned. The small hack in 0000996 also works for characters. Just press shift-I and within one click you see the hexadecimal value.
I would suggest if people have such strong feelings about Integer>>hex staying in the base system, they should file a bug report with a changeset that removes the deprecation status of hex.
 
(0001325 - 42 - 42 - 42 - 42 - 42 - 42)
ducasse
03-30-05 22:14

put in 3.9 6601 if anybody sees a problem.
 
(0002071 - 44 - 44 - 44 - 44 - 44 - 44)
MarcusDenker
08-01-05 11:12

fix attached, in need of beeing added to 3.9
 
(0002136 - 12 - 12 - 12 - 12 - 12 - 12)
MarcusDenker
08-04-05 23:55

added to 3.9
 

- Issue History
Date Modified Username Field Change
03-16-05 09:27 BGaertner New Issue
03-16-05 09:27 BGaertner File Added: HexFixes.1.cs
03-16-05 10:40 laza Note Added: 0001274
03-16-05 10:40 laza Assigned To  => laza
03-16-05 10:40 laza Status new => acknowledged
03-17-05 10:14 laza Note Added: 0001279
03-17-05 10:14 laza Status acknowledged => feedback
03-17-05 10:19 laza Issue Monitored: ohshima
03-17-05 10:19 laza Note Added: 0001280
03-17-05 10:32 bert Note Added: 0001281
03-17-05 11:38 laza Note Added: 0001282
03-17-05 11:39 laza File Added: vwi.jpg
03-17-05 14:47 laza Relationship added related to 0000996
03-18-05 03:23 ohshima Note Added: 0001285
03-18-05 10:22 laza Note Added: 0001286
03-18-05 10:24 laza Status feedback => confirmed
03-30-05 22:14 ducasse Note Added: 0001325
04-05-05 18:20 laza Relationship added related to 0000156
08-01-05 11:12 MarcusDenker Status confirmed => resolved
08-01-05 11:12 MarcusDenker Resolution open => fixed
08-01-05 11:12 MarcusDenker Note Added: 0002071
08-04-05 23:55 MarcusDenker Status resolved => closed
08-04-05 23:55 MarcusDenker Note Added: 0002136
03-16-07 16:11 laza Relationship added related to 0006339
03-31-07 14:11 jmf Issue Monitored: jmf
07-09-07 13:25 johnpf Issue Monitored: johnpf


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
106 total queries executed.
62 unique queries executed.
Powered by Mantis Bugtracker