Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000989 [tweak] Any block always 03-16-05 11:45 04-29-05 04:55
Reporter jens View Status public  
Assigned To
Priority immediate Resolution fixed  
Status resolved  
Summary 0000989: user interrupt is broken in tweak 3.8
Description an infinite loop like:

[true] whileTrue: [Transcript show: 'bla ']

can't be interrupted by the user in Tweak 3.8
Additional Information
Attached Files

- Relationships

- Notes
(0001305 - 52 - 52 - 52 - 52 - 52 - 52)
michael
03-30-05 02:22

This is an absolute show stopper for productive work
 
(0001307 - 655 - 691 - 691 - 691 - 691 - 691)
tim
03-30-05 02:56

OK, just to be sure I tried it in a 'plain' 3.8-6599 image and all works as anticipated.

Tweak fails to write a debug.log which makes reporting problems a nice bit more complicated and tedious. Perhaps that was the plan ;-) make bug reporting painful and fewer will get reported...

However, on my RISC OS 3.8 VM I have no problem getting to interrupt the sample code. What VM did the OPR use?

I do note however that the changelog doesn't seem to get updated until the expression completes; which of course doesn't happen when you break an infinte loop with an interrupt. Good old '3+4' gets written to the changes file along with the expected $!
 
(0001309 - 486 - 504 - 504 - 504 - 504 - 504)
andreas
03-30-05 09:49

6293LowSpaceWatcherFix-dtl is causing the problem. If you revert to the original version everything is fine. This is one more example of #!@^ approval of critical low-level stuff with some poor idiot not even knowing what he's breaking - and some other #!@^ idiot approving this DESPITE the fact that she's got no #!@^ idea what the #!@^ thing is #!@^ doing.

Now, how are we going to fix this? I have no update stream for Tweak in 3.8 any longer. Suggestions are EXTREMELY welcome.
 
(0001324 - 409 - 421 - 421 - 421 - 421 - 421)
tim
03-30-05 22:00

Reverting 6293 in my TK4 image does resolve the immediate problem of being unable to debug a stalled xml file load on my pBook - cmd-. opens a notifier that is responsive and lets me try to debug. Not sure why it is apparently different between pBook and RISC OS. More testing to do.

A good first step would be a 'correct' fix for the original problem addressed by 6293, which was quite annoying in itself.
 
(0001326 - 1249 - 1307 - 1307 - 1307 - 1307 - 1307)
andreas
03-31-05 08:25

What was the problem? I still don't know what this is supposed to do. The preamble of the CS claims:

"The low space watcher is interrupted in the context of the wrong process when the eventTickler process (or other high priority process) is running. This prevents low space detection from functioning properly."

But this makes no sense. The low space watcher can be only be interrupted if it is running (non-running processes are never interrupted) but all the running low space watcher does is to throw up an interrupt (which we all agree on is the right thing to do). If the user presses Alt-period when this happens why would it be wrong to interrupt the low space watcher?

It is precisely the right thing to do (in fact, it is the only thing that can be done if we are to honor the user interrupt). You are experiencing what happens if we choose to ignore the *actual* running process in favour of some arbitrary process which has nothing to do with the problem. Now, the current situation might lead to the low space watcher being interrupt if you have a low space condition and hit alt-period but what else would we expect???

Whatever the problem this is not a solution. Tell me what the problem was and I will find a fix for it.
 
(0001449 - 23 - 23 - 23 - 23 - 23 - 23)
andreas
04-29-05 04:54

Fixed via Tweak update.
 

- Issue History
Date Modified Username Field Change
03-16-05 11:45 jens New Issue
03-30-05 02:22 michael Note Added: 0001305
03-30-05 02:22 michael Priority normal => immediate
03-30-05 02:22 michael Severity major => block
03-30-05 02:56 tim Note Added: 0001307
03-30-05 09:49 andreas Note Added: 0001309
03-30-05 09:49 andreas Status new => feedback
03-30-05 22:00 tim Note Added: 0001324
03-31-05 08:25 andreas Note Added: 0001326
04-10-05 20:51 lewis Issue Monitored: lewis
04-29-05 04:54 andreas Status feedback => resolved
04-29-05 04:54 andreas Resolution open => fixed
04-29-05 04:54 andreas Assigned To  => andreas
04-29-05 04:54 andreas Note Added: 0001449
04-29-05 04:55 andreas Assigned To andreas =>


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
64 total queries executed.
45 unique queries executed.
Powered by Mantis Bugtracker