Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000551 [Croquet] Jasmine major always 11-23-04 19:47 12-11-04 21:39
Reporter elenzil View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Product Build
Summary 0000551: frame rate damaged
Description Around Novemeber 18 some updates to the online codebase
dropped the framerate on my machine about 15Hz, from 48 to 33.

Also, the framerate is far from steady,
it jumps around from about 26Hz to 36Hz,
which produces a significantly Jerky feel to the experience.

I think the framerate has always fluctuated a bit (why?)
but now that it's slower the effect is much more noticable.

I keep thinking things i've done have messed up the Hz
and then realized it's still this.

Other folks are seeing the same thing.

Steps To Reproduce
Additional Information
Attached Files  Hz1.jpg [^] (150,353 bytes) 11-30-04 03:49
 Hz2.jpg [^] (128,123 bytes) 11-30-04 03:49

- Relationships

- Notes
(0000732 - 779 - 833 - 833 - 833 - 833 - 833)
Croqueteer
11-23-04 22:16

I went through many of the change set versions that I have and the results I have on a Mac 17-inch powerbook in the full TeapotMorph without moving (same location as when you start up) are:

Croquet 0.1 17 Hz
Change set 141 20 Hz
Change set 149 25 Hz
Change set 152 25 Hz
Change set 153 29 Hz
Change set 167 28 Hz

These are pretty constant rates with a little drift. I also looked at the change sets around the time you list and the only thing that could have any change on performance would be modifying the stepTime of TeapotMorph. Unless you set the higher performance option in the general preferences, this should have no effect. Please give me a bit more info about this - what machines you have, and what kind of environment you are doing this in.
 
(0000733 - 457 - 457 - 457 - 457 - 457 - 457)
Croqueteer
11-23-04 22:22

Are you moving around when the framerate is changing? The amount that you have to render can vary tremendously depending on what you are looking at. There is a bit of flunctuation due to a number of factors, from garbage collection to messages being serviced, other Squeak processes being serviced, and other applications besides Squeak running. If you are not changing your view, but are seeing large changes in framerate, that would be interesting to see.
 
(0000778 - 211 - 235 - 235 - 235 - 235 - 235)
elenzil
11-30-04 03:49

bizarrely,
i'm seeing a stable 44ish Hz when the TeapotMorph is partially occluded by another squeak window (in this case a Workspace),
and an unstable 24 - 37Hz when NOT occluded.

see attached screenshots.
 
(0000779 - 107 - 111 - 111 - 111 - 111 - 111)
elenzil
11-30-04 03:53

the above turns out to be dependant on the precise geometry & placement of the occluding window. but still.
 
(0000780 - 1010 - 1172 - 1172 - 1172 - 1172 - 1172)
elenzil
11-30-04 04:01

howdy croqueteer -
sorry i didn't get back to you sooner,
i only just changed my Mantis preferences to include notifications. (hopefully)

this is on a winXP box purchased near the begining of this summer,
so there's plenty of horsepower.
ATI Radeon 9800 Pro,
3.2Ghz CPU,
plenty of memory etc.
It's being seen on another similar box in our office as well,
as well as some anecdotal confirmation from the croquet devlist.

I see the framerate issue whether or not the avatar is moving,
and whether or not there's any user interaction at all, actually.

I'm definitely seeing a 10Hz+ fluctuation when i would expect
a pretty constant framerate.
(I have some familiarity with framerates,
i've been a professional 3D programmer for about a decade)

How can i install changeset only thru a given release ?
If i could do that and had some rough list of
which changesets correspond to which dates
i'd be happy to locate which exact one caused the change.

thanks for looking at this.

Orion
 
(0000871 - 222 - 222 - 222 - 222 - 222 - 222)
Croqueteer
12-06-04 21:44

Try turning off the vertical retrace sync in OpenGL (see display properties...). We found a similar problem associated with faster machines due to a syncronization block when you try to render too soon after the page flip.
 
(0000872 - 286 - 322 - 322 - 322 - 322 - 322)
elenzil
12-06-04 22:43

By display Properties you mean the system wide display props ?

I get the same results whether 'Wait for Vertical Sync' is on or off.

- I did find and turn on the card's antialiasing, and it's quite nice tho!

- Is it possible to update a clean image only thru a certain update ?
 
(0000880 - 686 - 810 - 986 - 986 - 986 - 986)
elenzil
12-09-04 01:16

I've uploaded my most up-to-date image which has the old, good framerate.
http://www.elenzil.com/orion/citris/last%20fast%20croquet.3.zip [^]

---

this is the most recent image i have which has the original fast & stable framerate.

if i open a TeaTest and display the framerate,
i get a solid 48-49 Hz on my machine.

unfortunately this image breaks if updated from the server,
but to compare, start from a clean croquet image, update,
and do the same thing.
in the current version my framerate fluctuates between 25-37Hz.

This is of course hands-off after opening the window.
That is, no user input, no moving the avatar,
no other processes, etc etc.

Orion
20041208
 
(0000909 - 584 - 602 - 602 - 731 - 731 - 731)
Croqueteer
12-11-04 21:39

Durn that was hard. Turns out that just after Orion's last fast version, we made a change to the TeapotMorph>>#stepTime method such that it returned 20 instead of 0. Later, this was changed to return 1 if the highPerformance setting was on. See the Preferences (under the help menu) performance. Set highPerformance enabled. After doing this, I have essentially the same frame rate for both Orion's old fast version and the most recent change set (0000183). Thanks for posting your change set Orion. I might never have figured it out without it.

When in doubt, consider the obvious...
 

- Issue History
Date Modified Username Field Change
11-23-04 19:47 elenzil New Issue
11-23-04 22:16 Croqueteer Note Added: 0000732
11-23-04 22:22 Croqueteer Note Added: 0000733
11-30-04 03:49 elenzil Note Added: 0000778
11-30-04 03:49 elenzil File Added: Hz1.jpg
11-30-04 03:49 elenzil File Added: Hz2.jpg
11-30-04 03:53 elenzil Note Added: 0000779
11-30-04 04:01 elenzil Note Added: 0000780
12-06-04 21:44 Croqueteer Note Added: 0000871
12-06-04 22:43 elenzil Note Added: 0000872
12-09-04 01:16 elenzil Note Added: 0000880
12-11-04 21:39 Croqueteer Status new => resolved
12-11-04 21:39 Croqueteer Resolution open => fixed
12-11-04 21:39 Croqueteer Assigned To  => Croqueteer
12-11-04 21:39 Croqueteer Note Added: 0000909
12-11-04 21:39 Croqueteer Assigned To Croqueteer =>


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
73 total queries executed.
47 unique queries executed.
Powered by Mantis Bugtracker