Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006767 [Squeak] Network minor always 11-14-07 22:06 03-05-09 10:36
Reporter richardeng2005 View Status public  
Assigned To gokr
Priority normal Resolution fixed Platform
Status assigned   OS
Projection none   OS Version
ETA none Fixed in Version Product Version 3.9
  Product Build
Summary 0006767: SMTPClient bug
Description I get the following error message:

TelnetProtocolError: 501 malformed auth input (0000005.5.4)

Here's my test Squeak method:

mailTo: userAddress subject: subject text: text
    | client |
    client := SMTPClient openOnHostNamed: 'host_mail_server' port: 25.
    client user: 'my_user_id'; password: 'my_password'; login; initiateSession.
    client mailFrom: 'my_email_address';
        recipient: userAddress;
        data: text.
    client quit.

I managed to find a fix. In the #encodeString: method of the #SMTPClient in the Network-Protocols package, amend the last statement to read:

    ^ str truncateTo: (str size - 2)
Steps To Reproduce
Additional Information
Attached Files

- Relationships
duplicate of 0006843closed gokr Trivial fix in SMTPClient>>encodeString: so that it does not include NULL characters 

- Notes
(0013006 - 20 - 20 - 20 - 20 - 20 - 20)
gokr
03-05-09 10:36

6843 has better fix.
 

- Issue History
Date Modified Username Field Change
11-14-07 22:06 richardeng2005 New Issue
11-14-07 22:06 richardeng2005 Status new => assigned
11-14-07 22:06 richardeng2005 Assigned To  => cdegroot
03-05-09 10:36 gokr Relationship added duplicate of 0006843
03-05-09 10:36 gokr Status assigned => closed
03-05-09 10:36 gokr Note Added: 0013006
03-05-09 10:36 gokr Resolution open => fixed
03-05-09 10:36 gokr Status closed => assigned
03-05-09 10:36 gokr Assigned To cdegroot => gokr


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
45 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker